Main Site Documentation

Maximum current on 5v in/output


#1

Hi,

I was searching this forum for quite a while now, but i can’t really find my answer.

I’m using a FEZ Domino at the moment and i wanted to know how much current(in mA) the 5v output pin could deliver.

While searching i found threads about the maximum current on i/o’s, but not the 5v line.

Thanks for your responses in advance!

Kind regards,

René Vos


#2

It is a factor of the input voltage. The regulator itself can handle 800mA bu then the regulator will over heat.

Let me ask you this, what are you trying to do with 5V then I can tell you if you can or can’t do it?


#3

Hi Gus,

First of all, thanks for your quick reply!

I’m trying to connect 4 IR proximity sensors. These sensors hava a maximum current of 40mA each, so that would be 160mA for a combined maximum.

So i need to know if the 5V line is capable of pulling that kind of a load, or if i need to get my juice from the main powersupply, with a voltageregulator.


#4

What is voltage of Your main power supply?


#5

Yes you can do that. But your input voltage should be about 7V…9V may work but you have to try it


#6

Hi Gus,

I want to use ADH8066 GPRS modem (http://www.sparkfun.com/products/10138 ) from sparkfun.com with FEZ RHINO. I have done some wiring via UEXT on RHINO, when i run startup procedure (setting pin low and high) I got “READY” from modem, but that’s it, no other response, just time out, when I use my cell phone to dial modem’s number it tells me that it is N/A.

Could it be some kind of limitation of current or low voltage ? Using 3V3, but minimal voltage in datasheet of modem is 3.4V.

Thanks for reply.

John


#7

Connect a scope and see what is going on the wires maybe?


#8

Sorry don’t have any :slight_smile: Any other suggestions ?


#9

you could always just issue the AT commands like the person in the comments on the sparkfun site does. AT should give you an OK at least… The subsequent ommands should all end up with an OK response too…


#10

Hi Brat,

thank you for you reply. I have tried this before with loop sending only “AT” and got response on “OK” properly, but only for first one and then module stops replying at all.
Now I hooked up multimeter to see current coming in to the module, it goes from 20mA to about 70mA and then 0mA, so it appears that module get’s running and after a while shut down it self or get crashed.

Thanks,
John


#11

Is this to the VCC in to the module? how have you got this wired - pictures might help? And to me it seems that there is more likely an issue with the device moreso than anything else - don’t suppose you have another one to try? Or have you tried it on it’s own connected to a PC or anything? (if oyu haven’t and you don’t know how to connect it, don’t just jump in and wire it up :slight_smile: )


#12

Well i just jumped in :), but read data sheet how to wire things up first.

There are my connections:

RHINO------GSM
IO8-----------IO10 (AT indicator)
IO6-----------IO03 (GSM indicator)
IO3-----------TXD0
IO5-----------RXD0
IO12---------RI0 (RING)
IO11---------CTS0
IO1-----------RTS
IO10---------ON_KEY
GND---------GND
3V3----------VBAT

Well don’t have another one to try and tried it only with FEZ :smiley: Difficult to help me out, right ?

Thanks,
John


#13

Modem detail


#14

and where exactly did you measure the current ? If you’ve had to wire things up yourself, the pics that might be most helpful are the ones of both ends of your connector.


#15

Exactly between VBAT ON GSM module and 3V3 on RHINO.


#16

I would suggest then that you look at reproducing this outside the Rhino with it’s own power supply. If the module still drops its power consumption like you saw before, I’d see if someone else who has this (ie hit the sparkfun forum) can repro this on their module that they know is working. Seems very weird - plus I just realise we’ve taken this far from the original topic!