Mac computer

Hi Everyone,

I’m a PC user myself but am going to give some gadgeteer workshops to design students - who inevitably love Mac’s. I’m aware there is no visual studio express 2010 for the Mac but has any had experience of running it on an emulator. I’ve never used a mac in my life so I’m a bit ignorant of whats required.

Any advice or experiences would be much appreciated.


VS can be run inside with windows installed in virtual environment on mac.

For example:

Perfect thanks. As long as there is no known problems with drivers and things then that’s all I need to know.

There are issues running Windows VMs with some of the boards.

I develop for a Spider board using WMWare’s Fusion product with Windows 7 on an IMac and have no problems. But, I know there is a problem with the Hydra.

Do no assume all the boards will work on a VM.

With a Mac there is also the option to run Bootcamp. The feature allows a Windows operating system to run natively on a Mac.

It’s really going to depend what people are running PC on Mac wise then.

We’ve got some Spiders and Cerberus (which I’ve not tried yet) but are good for students because of the price (though they can afford the best Macs!).

I’ll perhaps just stick with those running Windows and Bootcamp and have some PC’s on stand by.

I guest that’s something nice about the Arduino - that even though the environments not a patch on visual studio it’s pretty universally installed.

The only way I have successfully developed witht the Hydra on a Mac is to install windows in bootcamp. I have tried dveloping in vmware fusion, but the USB drivers don’t work, so it is not possible to deploy code to the board from visual studio.

Once I installed Windows (2k8) on bootcamp everything work perfectly

@ Michael Warnes - Did you ensure to allow the VM to access that USB device? Even though it should work automatically, you may have to configure the virutal environment to strictly use the USB device. I do not know if this feature is available in the free versions of VMWare, but I know it is available in VirtualBox.

Hi James, I specifically allowed the USB device exclusively to windows in the VMware settings. The device was recognized and showed correctly in device manager. The problem I found was that it ws not possible to deploy in debug from visual studio 2010. I tried it using VM Fusion versions 4 and 5 with no success and the same failure each time. i.e.
[ul]The hydra drivers installed correctly[/ul]
[ul]The hydra listed correctly in device manager[/ul]
[ul]Unable to deploy to the device either in/not in debug in visual studio 2010[/ul]

…pretty much lost 2 days of my life trying every combination I could think of!..As I say, once I fired up Win 2k8 from bootcamp het presto! straight in!

If you do manage to get this working in a vm (that is not bootcamp) then let me know, otherwise I hope you find this information useful, are you looking into rectifying the USB drivers for VM’s on a Mac?..if so I’d be happy to help out with testing etc…

Just out of interest has anyone got it working with Virtualbox then?

searching the forum would have shown you this has been a problem since the hydra was released.

yes that’s correct…kinda, although I thought it might be worth ‘clarifying’ :slight_smile:

@ Andre, I tried alot of the points on the link you showed, specifically point 9 and reconnecting the device. I also tried to set all the different quirks modes in the .vmx file as suggested in other posts on that forum, but kind of came to the conclusion that I was spinning my wheels.

Although it would be very nice to have a set of working USB drivers for a Mac VM, it’s not the end of the world!, and as I say the workaround would be to use windows in bootcamp