Main Site Documentation

MAC Address Issues


#1

Hi All

I have working with a FEZ Cobra for a few months developing a C# app. Although I read much of the documentation I never picked up that these boards do not ship with their correct MAC address, and these need to be applied to the device via MFDeploy.

Yesterday I started uploading my application to three new FEZ Cobras. The first device had a MAC address of:

00-1A-F1-00-42-0D

which I recognised as this was the same MAC address used in my test device. I used MFDeploy to update the MAC address to the one printed on the sticker and rebooted the device which worked.

I then tried to do the same on another new device, and noticed that it had a default MAC address of 00-00-00-00-00-00. I updated it using MFDeploy which seemed to work, but when I restarted the device it had gone back to the default of 00. I then updated my software to set the MAC address, but the device is still not holding this MAC?

Out of 4 devices, only 2 are retaining the MAC address I set?
Why would two new devices have different default MAC addresses?
And why aren’t the MAC addresses set at the factory?

Any help appreciated!


#2

Those devices probably have outdated tinybooter or corrupted configuration. Please reflash your device.


#3

Hi Gus

All of the devices where re-flashed to v4.1.8 prior to installing the software.

I had to do this as my test device had been running 4.1.6, and the three new devices came installed with 4.1.7.

When I updated my GHI SDK installation it turned out the Dll’s where version 4.1.8 so I needed to udpated both my Dll’s and the devices.

I will try flashing them again to see if it makes any difference.

Adrian


#4

Hi again Gus

I have re-flashed the device but it still seems to be loosing its MAC randomly. I haven’t been able to pin it down to set sequence of events. I had a feeling it might have something to do with a failed deploy of the software, but I just had it running for a few minutes and restarted the device to find it had lost the MAC again.

Could an issue with the on-board battery cause this sort of behaviour?

Adrian


#5

Writing to flash is power critical so it is possible that flash write would fail with unstable/weak power.