Main Site Documentation

Losing faith fast in Gadgeteer, can anyone help


#1

Hi,

We are looking for some help to reinvigorate my faith in .Net Gadgeteer. We are trying to get through ‘Getting Start with Fez Spider Kit’ instructions from GHI. It says, “within 30 minutes you will be working and ready” or something similar. We are on day 4 :-).

Where to start? I should say we have read through a lot of material on the Community forum, so not lazily batting out questions for help.

We are running Windows 7 Professional (64 bit) with full admin privileges. We are using Visual C#2010 as our programming environment.

Our main problem (I think) relates to USB - we are just getting no where, it seems a little random whether the computer detects the DP board (and its associated bits).

We did today get a final camera, screen and button setup working, only then to have it caught in an endless loop of not being able to get the computer to ever recognise its existence once unplugged and re-plugged - USB problem?

We therefore pulled another spider kit from the box and attempted a second go. We thought the problem above might be due to firmware issues, as we had been getting problems with VSC#2010 Express deploying the software (we were initially getting a mismatch error statement " "). So we did this using the file downloaded from GHI (Config_Fez v013 beta). Unfortunately, this highlighted another error - once deployed to the new gadgeteer that unit stopped working too.

Does anyone have any pearls of wisdom to help get a Gadgeteer up and running? Are we on the right line with the idea this is a USB problem? We want to run a workshop (next Tuesday!) on using this technology to help prototype ides for monitoring biodiversity.

Cheers. Matt


#2

Hi mjw205 and welcome to the forum.
First thing i would recommend is to always use a powered USB hub or connect directly to the PC USB port.
Secondly download and install the latest SDK etc following the install instructions here to the letter.
Always make sure your Firmware on the spider is the latest version.
You may also find it better if you use the WinUSB driver rather than the cdc driver that gets installed by default. Its muc more reliable. To do this you need to go to device manager and right click the device and update teh driver with the one in C:\Program Files\GHI Electronics\GHI Premium NETMF v4.2 SDK\USB Drivers\GHI_NETMF_WinUsb
That should solve the USB detect issue and you can carry on from there.

Please feel free to ask questions here, we are all here to help.


#3

Hi Hugh. Thanks for the reply. Yep, we are working directly from a USB port in the back of the computer, we were working from a USB connection in the side of the monitor - but changed to a USB port in the PC yesterday - just in case it was a power issue.

We are using SDK 4.2 QFE2 (as I take it this is needed if you want to program using Visual C#2010 Express). Effectively we have installed everything as indicated by steps 1 to 4 on https://www.ghielectronics.com/support/.net-micro-framework.

Firmware on the Spider might be another sticking point for us. Here are our current versions (from the Fez Config Software after clicking ‘Connection’).

Connecting to device…EMX_EMX
Loader (TinyBooter) Version 4.2.7.0
Firmware (TinyCLR) Version 4.2.10.1

On to USB. This is a major problem for the four units we have tried. Now that they have all been exposed to Windows they (the Gadgetters) never now appear in the Device Manager (under USB controllers)… so we can’t change the driver used.

Matt


#4

Power still remains an issue. Going from a monitor USB port to a PC one will not solve it. You need a powered USB hub. Something like this: http://www.newegg.com/Product/Product.aspx?Item=N82E16817182212


#5

If you are not up and running in minutes, then we are always here ready to help.

The best place for now is to check this and let us know where you see the problem.
https://www.ghielectronics.com/docs/165/netmf-and-gadgeteer-troubleshooting


#6

Thanks Josh and Gus. I will pop out and buy a USB powered hub now.


#7

I’ve been using this powered hub and had no problems:

Is the hub your using USB2 or USB3?


#8

I have three of those also and they’ve worked great so far. They aren’t as high quality construction as I’d like but they do seem to function fine.


#9

Hi Matt, welcome to the forum.

Yep, you ALSO need to fix your firmware issue. You need to update the tinybooter to the 4.2.10 version. You can’t do that with the current fez config tool, you need to either use the legacy updater or the manual process.

(Gus and team, is this tool really worth having as the main tool listed given the beta nature and this limitation?)


#10

Hi Brett. Thanks for the reply. I just spent the past few hours messing with the Gadgeteer while my girlfriend working on Arduino is power past me…ha ha…very different beasts I know.

We now have an independent power supply going into the power socket on the DP board - we thought this might be a good idea as we eventually want to build a whole load of these and distribute them across the campus to do all sorts of random stuff (hence not powering permanently through USB will be a priority once we have tamed ‘Gadgeteer’…).

Having been through all of the bits of the Gadgeteer troubleshooting website, along with re-reading material we realized the Config v013 programme kind of only does half of what we thought it was doing. I was going to use the legacy tool and thought ‘legacy’ kind of suggested it was for updating older versions. But given what you said, I will try the legacy updater now. Cheers


#11

So. Inside the legacy updater tool for EMX …

The software instructs pins IO4, IO0 and IO30 to be set to LOW first, then reset device, then set these pins to HIGH. What does this mean with respect to the EMX Fez Spider board and its switches and their positions. I have the handy little piece of card that comes with the Fez Spider Boards but not too sure how I link that info with the instructrions in the legacy updated software to decode the instruction above. Some guidance would be awesome. Thanks


#12

I don’t know for sure, so I always fall back to the “manual” process - since you’re using Spider, you need to use EMX’s guide https://www.ghielectronics.com/docs/54/firmware-update-emx

I think the switch settings will be the “tinybooter” mode??


#13

When did you last read the EMX firmware description? The doc was updated to include position of spider switches. That said, I’d suggest using andre.m’s suggestion as it is easiest for beginners. There is a link to our legacy firmware apps, go to our home page, click on support, click on .NET Micro Framework, and find step 4. (The emx firmare update instructions are on our list for a thorough edit)


#14

Hey Jeff, and all those that kindly replied. We have fixed all the problems now, partly linked to the GHI website recommending using VS2010, but that firmware 4.2.10.x (supplied on the mainboards) only works with VS2012. We ran a great workshop today with 20 people at the University of Exeter and from a Digital Fabrication research group, and ran through 4 Gadgeteer projects (camera, GPS [problem with that one - will make another post on that front], a gas sense project and the pulse oximeter project). Microsoft Research came too (all the way down to Cornwall - about 7 hours from where they are based in Cornwall). Also squeezed in some Arduino projects too. Many thanks again. Matt


#15

Hi Matt,

Great to hear it was a success - but just wanted to make sure that you knew the correct story about the VS2010/VS2012 situation. The SDKs work with either version, but you have to install specific components depending on what VS version you intend to use.

If you have or want to use VS2012:

  1. Install VS2012
  2. Install netmf SDK 4.3 RTM
  3. Install GHI SDKs

If you have or want to use VS2010:

  1. Install VS2010
  2. Install netmf SDK 4.2 QFE2
  3. Install GHI SDKs

Either way, you get the same GHI SDK, with the same features and firmware. Either works fine.


#16

Not sure what the issue was … but there were quite a people frustrated with the GPS module available from the catalog. Also, there were certain boards (Hydra I think) that had issues with other GPS modules.


#17

Yes, Hydra does not play well with GPS


#18

We are suffering from two issues: a) “buffer ovr” (being reported on the Display_T35) - on some occasions, b) reporting of ‘NO POSITION FIX’ for more than 20 minutes or so - when it doesn’t report “buffer ovr”. We have read through much of the available material on the forums and updated drivers etc. as recommended, also checked the GPS was not part of the recalled batch [it isn’t]. Not sure what else to do, perhaps some more detailed debugging might help?


#19

from a GPS fix perspective, were you outside, with clear uninterrupted view of the sky horizon to horizon?


#20

Hi. Code developed indoors and device checked outside with good clear uninterrupted view of the sky (we are on a hill in a semi-rural area in SW England). Unit powered outside by the UC 4 x AA power pack. We have applied one recommendation, to change the UpdateRate to 5. But alas no effect. Also updated drivers. We used this code: http://www.netmf.com/gadgeteer/showcase-item.aspx?id=175&title=Module%20Tutorial:%20%20Seeed%20Studio%20GPS
and from http://gotoloop.wordpress.com/2011/12/05/net-gadgeteer-gps-module/#comment-16.