Main Site Documentation

Loading TinyCLR


#1

Hey everyone,

I begin with my FEZ Cerbuino Bee and I have a problems.
In a first step, I added a header on my mainboard and I loaded a TinyBooter version 4.2.6.1.
second step, I wanted load a firmware 4.2.6.2 with FEZ Config as explained on this page : https://www.ghielectronics.com/docs/127/firmware-tinyclr-update

But just after started, a popup opened with a failed message “Interrupt while deploying. Updating failed!”.
I tried changing a USB port but I had the same result (cf https://www.ghielectronics.com/community/forum/topic?id=14674).

At beginning I worked into a virtual machines with Windows 7 Pro x64 and after I tried again directy on my computer.
I download last SDK release (NETMF and Gadgeteer Package 2014 R1).

You will find in attachment my screen shot…

Could you please, help me for loading the firmware ?

Thank you very much in advance.
jp


#2

Welcome to the forum - yep, we’re here to help you out !

you have ticked the Ethernet firmware, can you confirm you have the ENC28 module connected in the correct socket when you’re doing the firmware update?

Can you also try without the Ethernet firmware to see if that changes the behaviour?


#3

Hi,

I haven’t the ENC28 module… I have retry with unticked the ethernet firmware. It’s the same message.
I try to load both firmware (ethernet and non ethernet) but without change.

I added an external power for trying and I run FEZ Config as administrator.

I’m really blocked and I don’t know what to do…

thanks.


#4

I just read this topic : https://www.ghielectronics.com/community/forum/topic?id=14905&page=1#msg150590

Last post says it uses a ‘dual power USB’ cables. What is difference in use this cable and external power ?

You think of my problem is due a lack of Power ?


#5

If you have added an external power supply of sufficient voltage and current (you can tell us the OUTPUT info from the power supply to help validate it) then that should eliminate this as a possible problem. If you only used the USB for power and your laptop wasn’t providing enough current or stable enough voltage, this might lead to issues. However, I don’t think I’ve seen this actual error about interrupt while updating, so I don’t know what the possible causes are.

For giggles, can you go back and apply the tinybooter manually, as per https://www.ghielectronics.com/docs/55/loader-tinybooter-update-fez-cerberus and see if that then makes a difference?

Can you also try deploying the firmware to the Cerb with MFDeploy (I am not sure this is meant to work and don’t have a Cerb family device to try it on)


#6

Hi
I already had this problem.
The problem is that you do not have enough power supply … You must supply the card with an external power supply providing enough current (more 1.5A).
Best regards. Christian


#7

Of course, I use Power output with 1.5A max. My setup is 8v (normaly between 6 to 9v ?).
Tonight, I will try with other Power supply with more 1.5A, I’ll keep you posted…

thanks

jp


#8

I check my power supply and it limit to 1A. I have an other 3A output but the voltage is less than 5.5V. If you think that the problem due to external power, I’ll buy a other one this week-end.


#9

1A at 8v should be sufficient, depending on what it is powering - do you have any other modules connected to your device when you’re trying to update it? I personally would make sure you have NOTHING else connected and just use the 8v 1A supply and you should be fine. Having more power supplies is never a problem, either…


#10

Hi,

sorry for not giving news, I was on business trip…

With my old computer, I managed to load TinyBooter and TinyCLR without using external supply.
I reinstalled all GHI software on my new computer and now I don’t have problem for loading TinyCLR. Perhaps the problem was due to my first install…
I execute with successful a simple sample on my Fez Cerbuino :slight_smile:

With my virtual computer (on virtualBox) it doesn’t work… I can’t explain it…

Thank you for your help.
jp