Main Site Documentation

Loading programm to FEZ Reaper


#1

Hello Folks

I’m not really understanding this new forum structure… I hope I post this here correct >.<

I still have many old GHI mainboards and moduls and I wanna keep using them for a while longer.
I really hope there are still ppl around that can help me with those old modules.

Usually I’m getting stuck on the beginning… loading a program to the modul.

I updated all mainboards to the latest version.
But it seems something is not working in VisualStudio… any idea on this?

Thank you very much for any help.

Greez evul


#2

You updated them all to TinyClr?


#3

Uhmm… well, the latest available firmware 4.3

I’m sorry. I’m just a hobby programmer and know just basics :confused:

It seems that the board is connected and recognized by the PC… but VS can’t find it somehow


#4

I won’t find it if another process is holding the port open. Make sure you close the config tools et al before you try with visual studio. Also, try running VS as administrator.


#5

Restarted pc to make sure the update tools are out of the possibility.
Also restarted the mainboard.
Also checked that the project is created as 4.3 project.
And started VS as admin.

Anything else I can check.
And settings to do in VS?

I have about 4 FEZ reaper mainboards… and if those won’t work I can throw all stuff into trash -.-"


#6

there is no need to run vs with admin rights
in your project settings try to switch transport to serial and back to usb and try to deploy your project


#7

Where do I find such a setting?


#8

With GHI, you will always be able to use old products, or at least to shoot for that. You need to start here http://docs.ghielectronics.com/hardware/legacy_products/gadgeteer/intro.html


#9

right click on the project select settings and after settings are open on the left


#10

OMG… it worked!
I can load my test program on it <3

The transport switching did it!
I’m so happy right now :smiley: I already got panic that my two boxes full of GHI material would be useless now.

Now I just need to find out how to activate the “output” window while debugging. But that should be managable.

  • edit: found it ^.^

Thank you all for your help.

Greets evul


#11

glad it helped


Wow, this place has become quiet