Main Site Documentation

Listening keyboard


#1

Hi all,

I have :

Fez Panda II running 4.1.5.1
connect shield
Serial to USB Converter http://www.ghielectronics.com/catalog/product/266
Leds
and a USB keyboard.

How can i listen keyboard and when i push eg. A for LedYellow, B for LedGreen?

I just want to how to listen the keyboard.

Thanks a lot.


#2

Do you mean a USB Keyboard?


#3

yes sure, a USB keyboard.


#4

unless someone has figured out how to communicate with HID’s trough the serial port it wont work. you could put a PS/2 keyboard plug on it and “talk” to it on digital pins, but i’m not sure if you will get the timing right with netMF. specs for PS/2 keyboards are here: http://www.beyondlogic.org/keyboard/keybrd.htm

//Tomas


#5

See the link below (USB keyboard with FEZ Domino)

http://wiki.tinyclr.com/index.php?title=FEZ_Domino_USB_Morse_Keyboard


#6

Thanks for replies.

I use Fez Panda without any USB input.

I am using this http://www.ghielectronics.com/catalog/product/266 card to get input from keyboard. Unfortunately i couldnt find any usage documentation or tutorial about this card.


#7

You can add USB host capabilities to Panda as well:

http://ghielectronics.blogspot.com/2011/03/usb-host-support-is-added-on-fez-panda.html


#8

offffff,

i tried http://code.tinyclr.com/project/191/telnet-type-class-for-netmf/ and when connecting Panda to my PC, it recognizes it as two devices named as, USBizi and CDC VCom. And drivers cannot installing successfully. Now i cant do anything with my panda :’(
Please help me :frowning: Is this problem cause of my PC or Panda? What can i do?
Thnx.


#9

And Architect, i also know your link about mp3 player.

I tried various of codes to implement this. But my deployment device is USB. I dont have a RS232 device. I want to deploy and use same serial port on Panda II.


#10

hi again, i tried to use another computer but problem didnt solved. When i connect panda to PC, there are 2 unknown drivers in the Device Manager named USBizi and CDC VCOM :frowning:

Please masters. Help me to solve this issue :frowning: How can i convert it to factory default or something else ?


#11

Start MFDeploy, select USBizi and click ERASE


#12

with MFDeploy i cant see USBizi. so icant erase.


#13

You might need to erase it in bootloader mode - hold LDR button down when you power up the device, and follow the information on erasing and reapplying firmware as described here http://wiki.tinyclr.com/index.php?title=Firmware_Update_USBizi


#14

i tried pushing LDR and then connecting to PC but PC didnt recognized the device. Because of nothing in USB section in MFDeploy, i cant update firmware.
Regards.


#15

I had a similar problem a couple of weeks ago.

I ended up un-installing and then re-installing both the BootLoader USB driver and the “debug” USB driver.


#16

thanks for your answer. I downloaded the ghi 32bit drivers from the site. Uninstalled the current driver and reistalled. But after reinstalling the driver and connecting, again there are two different drivers with unknown. Problem didnt solved yet. If i buy a rs232 to debug on serial and erase the program, can u guarentee that it will be solved? I dont want to buy a panda ii for this issue yet.


#17

this is solvable without added expense - thats what these devices are about.

The fact that you have devices that do not have drivers means you need to work to resolve that. You have told us nothing about your PC, whether it’s Windows 7 or not? Post us some pictures of what you see in Device Manager and what you did when you said you uninstalled / reinstalled the drivers so we can assist with the troubleshooting of that.


#18

My OS is Windows Vista but also same problem occured in Windows 7.

I added the captured Device Manager when I connected device.

Regards.


#19

thanks for your replies, i solved the issue. i reistalled the firmware and my panda is working properly now :slight_smile:
have a good day! :smiley: