hello sir

please may i ask , about the led 7c,
i have a raptor board, and connected the module on the raptor connector number
9 and the power to connector 8

i just have write LED7c.SetColor(LED7.LEDCOLOR.blue);
and i have Always a faillure
i have looked at internet; but there is not a single information, on how to program that led
please can yo help me to initiate just the led7c on

many thanks

marc debruyne

@ debruyne -

Use any X socket

May help you.
See: https://www.ghielectronics.com/docs/7/digital-outputs

led1 Socket pin 3
led2 Socket pin 4
led3 Socket pin 5

You can find the driver here.

@ debruyne - what is the failure? Maybe post a screenshot.

Welcome to the community

hello willgeorge

thanks for the help

but i tryed to write a bit youre program example, but i have still a problem now with socket

here is a copy of my file

please can you inform me whats wrong on that programm

many thanks

marc debruyne

@ debruyne, I don’t have a Raptor and so haven’t tried this, but if you use the visual designer to attached the module to your raptor then you should be able to address them as such:

    public partial class Program
        // This method is run when the mainboard is powered up or reset.   
        void ProgramStarted()
            // Use Debug.Print to show messages in Visual Studio's "Output" window during debugging.
            Debug.Print("Program Started");

            new Thread(() => FlashLED()).Start();

        private void FlashLED()
            for (; ; )

hello jason,

thanks , but still i have a problem it does not reconise LED7C

see attached screen

marc debruyne

can I ask you to step through creating a new project for this ? On the screen where you pick your mainboard, there’s a 4.2/4.3 version drop-down selector. Can you make sure you have both 4.2 and 4.3 listed, and can you make sure you select the 4.3 option when creating your project ?

Can you also show us a screenshot of your program.gadgeteer page in VS?

(I’ve just tested a vanilla project in 4.3 and everything just worked as expected - so there’s two possibilities spring to mind, either you did 4.2 when creating the project, or you haven’t installed a recent SDK. Lets confirm the first thing first!)

You appear to have used the type and not the instance of LED7C. If you look on the designer screen, the LED is actually called led7C, not LED7C. Case is important here.

Your code looks like


It should read



@ debruyne -

Sorry for the delay…
I do not have my Raptor now. Gave it to my son to show off to somebody. And I do not have the C7 only some multicolor ones.

@ Jason -

Good catch! I glazed right over that one…

Let’s hope he comes back and tells us how he’s got on…

hello jason

YES its ok

thank you very mutch

marc debruyne

1 Like

Marc, great news. Glad we could help get you started. Do be sure to come back and let us know how your project goes from here.