Main Site Documentation

KBE issues after Power Cycle + sometimes a delay of ~7 seconds is required after init


#1

Hi,
I am facing issues with the KBE
the following is the behavior:
when I do the init in the OS the KBE works fine in the OS, but then when shutting down and powering on, the KBE will not work. if I call stop and then init it will work. but when back to OS (without the init in the PreOS) the KBE works in OS
i.e. init is required to be called when there is a power cycle.
I have attached a sniffer to see the USB traffic behavior and there is a STALL Packet after the reset. - which mean the Device stopped working.

In addition besides the fact that the init is needed after the power Cycle after the init call sometimes, behaves differently on different platforms, a long delay is required before any key press (of the KBE) works some times ~ 7 seconds. (while delay varied)

  1. this seems like a bug is there anyone I can contact regarding this?
  2. I would like to try and fix- requires to detect the power cycle and then recall the init, where can I find the very low level code so I can check if this helps?
  3. any idea regarding the delay, what I saw in the computers which worked only after the delay, nothing was sent and after 4 packets of setupTXN, STALL Packet, and 2 packets of OUTPUT TXN the keystroke command was sent and worked.

thanks!


#2
  • there was at the time the bug that KBE did not work in preOS this was fixed in MF 4.2 what was the fix? this might help with the additional fix which is needed