Main Site Documentation

Just update the firmware and Device not found or cannot be opened - USB:Gadgeteer


#1

Hi,

I just update my Spider to Loader version 4.2.10.0 and Firmware version 4.2.10.0. However, after updated and tried to deploy a very simple application, basically just Debug.Print(“something”); Though it seems that VS cannot find the device and said that
"Device not found or cannot be opened - USB:Gadgeteer"

Though I tried with my friend’s device which has the same Loader version and Firmware version. It works just fine. Do anybody know what is wrong with my board?

Thanks a lot!


#2

@ littleting - welcome to the forum.
In VS go to project properties > .NET microframework Tab> and choose the spider in the device dropdown. Save the project and re deploy.
I get this all the time.


#3

@ HughB

Thanks a lot!! It work :smiley: I thought there is something wrong with the firmware that I just updated.

Though I am still wondering why. I mean I tried this with different computer and it seems that none of them recognize my device.

Thanks again!


#4

Glad i could help. Sometimes it seems that VS forgets that the device is connected and doesn’t deploy. re selecting it in the project settings always works.


#5

Welcome to the forum!

Did those other systems have the GHI device drivers installed?


#6

No they don’t, but they work fine with another gadgeteer device. That’s why I thought there was something wrong with my firmware. Also with another device, it work fine without me reminding VS that the device was connected. I actually tried to switch them back and forth and only my device that seemed not to work.

Also I worked with 4.2.9 before. It worked fine and I didn’t have to install the USB driver.


#7

You need to update the USB name. Using FEZ Config (found on our web-site under Support->.NET Micro Framework, step 4.

[ol]Plug your Spider in
In FEZ Config, Click on "Deployment (Advanced)
Under Friendly name click in the text box and type “Gadgeteer” and click “Apply”[/ol]

This is down in the EMX firmware update guide based on MFDeploy (the EMX guide is slated for an update!). If you don’t know how to find that guide, there are a couple of quick ways to stumble across it:

[ol]On our web site click Support->Documents and use your browser’s search button for firmware
Go to our web-site, go to the product catalog, find (you can use search at top of page) FEZ spider, click on Reference tab, select Developers’ Guide.[/ol]