Issue with deploying to SC13xxx

Hi all,

I have a project in Visual Studio 2022, which I want to deploy on the Fez Flea. It is just a simple project with a couple of lines of code to get started with I2C. I have in my project also the dependencies downloaded through NuGet (so Gpio, Native, I2C, Core).

When compiling the project, I see that everything is found and deployed:

Looking for a device on transport 'USB'.
Found device port 'USB' with ID '76eb2ad0-a64e-40cc-8077-257aee1fba7f' for transport 'Usb'.
Starting device deployment.
Attempting to connect to device 'USB:SC13048': iteration 0.
Opening port '\\?\usb#vid_1b9f&pid_5012#5&8925738&0&1#{c13bcfe9-5e84-4187-9baa-45597ffcbb6f}'.
Attaching debugger engine.
Debugger engine attached.
Generating device specific assemblies.
	- SPMT.Modules.I2CMotorDriver v1.0.0.0 with size 1.932 bytes at 'C:\Source\Workspaces\SPMT Control\SPMT.Modules.I2CMotorDriver\bin\Debug\pe\'.
	- mscorlib v2.2.0.4200 with size 72.560 bytes at 'C:\Source\Workspaces\SPMT Control\SPMT.Modules.I2CMotorDriver\bin\Debug\pe\'.
	- GHIElectronics.TinyCLR.Devices.Gpio v2.2.0.4200 with size 4.880 bytes at 'C:\Source\Workspaces\SPMT Control\SPMT.Modules.I2CMotorDriver\bin\Debug\pe\'.
	- GHIElectronics.TinyCLR.Devices.I2c v2.2.0.4200 with size 10.468 bytes at 'C:\Source\Workspaces\SPMT Control\SPMT.Modules.I2CMotorDriver\bin\Debug\pe\'.
	- GHIElectronics.TinyCLR.Native v2.2.0.4200 with size 6.200 bytes at 'C:\Source\Workspaces\SPMT Control\SPMT.Modules.I2CMotorDriver\bin\Debug\pe\'.
Total deployment size is 96.040 bytes.
Incrementally deploying assemblies to the device:
Allocating assemblies:
	- Address: 0x08047000 => mscorlib 
	- Address: 0x08058B70 => GHIElectronics.TinyCLR.Devices.I2c 
	- Address: 0x0805B454 => GHIElectronics.TinyCLR.Native 
	- Address: 0x0805CC8C => GHIElectronics.TinyCLR.Devices.Gpio 
	- Address: 0x0805DF9C => SPMT.Modules.I2CMotorDriver 
Deploying assemblies:
	- Writing sector 43 (2.048 bytes).
	- Writing sector 44 (2.048 bytes).
	- Writing sector 45 (2.048 bytes).
	- Writing sector 46 (2.048 bytes).
	- Writing sector 47 (1.856 bytes).
Assemblies deployed. There are 128.216 bytes left in the deployment area.
Restarting interpreter.
Attaching to device.
Waiting for device to initialize.

Afterwards, when starting in Debug, it says it cant find the Gpio and Native libraries:

Create TS.

Loading Deployment Assemblies.

Attaching deployed file.

   Assembly: mscorlib (  Attaching deployed file.

   Assembly: GHIElectronics.TinyCLR.Devices.I2c (  Resolving.

Link failure: some assembly references cannot be resolved!!

Assembly: GHIElectronics.TinyCLR.Devices.I2c ( needs assembly 'GHIElectronics.TinyCLR.Devices.Gpio' (

Assembly: GHIElectronics.TinyCLR.Devices.I2c ( needs assembly 'GHIElectronics.TinyCLR.Native' (

Error: a3000000

I also verified with TinyClr the deployed assemblies, and indeed Native and Gpio are not deployed. I have already erased the device several times, and also re-installed the latest firmwares. I also had this issue a couple of weeks ago, but that disappeared by itself after several retries, but I can’t get around it right now. What am I missing in my configuration, anyone who can help?


had the same problem and here is the solution that worked for me

Best regards

Thanks! Using the Erase All resolved the issue. I am sure I had done it already several times last days in addition to just the Erase and several times reflashing the firmware.

Apparently something gets locked in the device itself I guess, as even a new VS2022 project and another Fez Flea or Fez Pico were causing the same issues till I erased the whole device and reinstalled the firmware.

I have several fez flea boards and with all of them I had to “erase all” first to make the boards work.

This is not necessary for FEZ boards with SC201xx.

But good that it works now :slight_smile: