Is this Fez Cobra dead?

one of my Fez Cobra’s reset itself yesterday evening and on reboot had a solid white screen on the TFT. I checked everything initially, power, usb, etc.

When attached to the computer via the USB cable the only detected signal is the Boot loader. This is even without having to load the boot loader by pressing Up,Dn,Sel and Hitting Reset. It just appears to be booting into boot loader by default.

I attempted to reload TinyBooter and the NETMF CLR using both Terraterm and the EMX updater. With this I can get ping the boot loader, get the version, transfer the TinyBooter, etc.

However upon reset it just goes right back into the boot loader with a white screen. EMX Updater cannot get past the reset after the TinyBooter upload either.

Any suggestions on things to try with this product to get it back up and booted with the NETMF CLR?


Maybe your program is doing something?

No, because after a reset I never get any boot message on the LCD. No firmware output, nothing. And the app that was loaded on there prior to the reset was a glide UI app that really didnt do anything until user input was rec’d.

I’m pretty sure that the bootstrap and OS are dead – since I never get past the white screen and boot loader access after a reset.

You said you were able to load tinybooter or misunderstood!

Last thing to try, use a good power source and enter GHI loader to use E command to erase all. Then update from there.

sorry… I may not have been clear.

I can get into the boot loader with terminal program.

I can get bootloader version by hitting “V” (1.02)

I can “E” erase all

I can send the TinyBooter sent up via XMODEM

after the send is complete I cannot attach via netMF deploy or the EMX Update, only re-attach via the COM assigned to the boot loader. Even after a reset.

I have tried via USB. I have booted with an external 6V power supply, and attached this unit to the field hook-up which has a regulated 6V power supply going to the Vin pin.

What happens if you hit R? This should force run tinybooter, after you load of course.

After sending the EMX tinyBooter.GHI I press “R” and get “Bad Firmware”

This is the response I get if I use the EMX Updater tool that comes with the GHI SDK:

Connecting to device…
EMX found at Port#: COM3
GHI Bootloader Version: 1.02

Device will be updated automatically! DO NOT disconnect or turn off the device!
Erase successful!
Updating TinyBooter. Please wait…
Update successful!
Disconnecting COM3
No response from device

“Bad Firmware” to me would suggest that re-downloading the SDK and trying again with the firmware within that would be beneficial.

I know – I did uninstall/re-install the SDK and bits earlier today and tried with a fresh copy. I just think this controller is hosed :confused:

My new Cobra board should be here tomorrow, had it Fedex’d in.

Gus et al; Is there anyone I can send this other board back to and see if it’s totally shot and worthy of the trash-can? I’d pay you guys to take a look and see if it’s something we did or if it is even recoverable. If not it can be trashed; but I wouldn’t mind yet another spare dev card laying around if I can somehow get it working again.

Send to my attention and include a link to this post please.

See address on contact page.

Thanks Gus; Will ship it out Monday. Just let me know if it’s a total brick or worth any sort of repair.

Also, I got one of the replacement Cobra’s in the mail today. I went through the update process with the latest firmware from the same laptop and it was successful. We transfered our code, plugged it into the console, and everything is working great. Definitely something amis with that one unit.