Main Site Documentation

Interrupt while deploying error


#1

Hello,
I am trying to update my FEZ Spider firmware. It used to work earlier. But I had another tool for firmware update (Fez spider mainboard updater). Now with the new version, there is FEZ Config. I have got following error “Interrupt while deploying”. Anybody knows whats the problem?

If i try to upload firmware manually, it get bad firmware error in Tera Term :-/


#2

Ok, so I finally solved that. I installed old SDK 4.1 and using FEZSpiderMainboardUpdater I transfered firmware files from SDK 4.2 into my Spider. But I dont get, why it didnt work with terminal…


#3

I couldn’t get the 4.1 to see my Spider. Good idea though


#4

So I try and use the uploader to add in the 4.1 SDK hex files and now the FEZ CONFIG doesn’t see my board at all :frowning:

Any ideas how I can get my loader to work?

Just says device not working properly.

I am connecting the USB Client SP 1.3 (not DP) which I’m not sure should make a difference?


#5

I highly recommend to upgrade firmware on your spider to the latest, which is 4.2


#6

Thanks… I would absolutely love to.

Now that I have tried to update and for the “interrupt while deploying error” on firmware2…

I now have no firmware at all :frowning:

So, looks like I cant run my demo tomorrow.


#7

Updated firmware to Firmware (TinyCLR) Version: 4.1.8.0
by using the update firmware OTHER option…

Unfortunately the code I am using relies on 4.2 framework.

Perhaps I need to have TinyBooter updated too?


#8

You can check in release notes what is the latest version of the TinyBooter for your device. Compare it with the one on the device and if it is different then you will need to upgrade TB as well.


#9

Sorry I don’t know where to get that information.

I am using a FEZ Spider 1 and just want to run 4.2 on it.
I cannot update the firmware.

Loader (TinyBooter) Version: 4.1.6.0
Firmware (TinyCLR) Version: 4.1.8.0

I think the only thing different is that I am using USB Client SP (not DP). Does that matter?


#10

Ok. Here is the link to the Release notes on the latest SDK:

http://www.ghielectronics.com/docs/40/netmf-4.2-developer

•EMX (Spider) v4.2.10.1, TinyBooter v4.2.10.0

So the latest TB is v4.2.10.0 for EMX which the Spider is based on.

Please follow the instruction to update the TinyBooter first and then update the Firmware.

Latest SDK:

http://www.ghielectronics.com/support/.net-micro-framework


#11

thank you.

I’m still stuck on this im afraid. Im happy to play around but the instructions don’t make sense as they are written.

In FEZCOnfig the TinyBooter Updater says its not available. Id prefer to use a tool but I guess its in beta so still being development

So I click on the link
http://www.ghielectronics.com/docs/54/firmware-update-emx#521

It takes me to a set of instructions where I need TeraTerm (though link is broken).

Then in steps 6 and 7 ask to :

Connect back the development system.
Press and Hold UP, Select and Down buttons the press and release Reset button

Its not clear what this means as there is no select button on a keyboard and I don’t know how that would invoke the driver install.

Any guidance most welcome as Id like to get my project up and running for a demo today. Many thanks!


#12

teraterm binary: http://www.ghielectronics.com/downloads/bin/teraterm_utf8-4.53.exe
teraterm zipped: http://www.ghielectronics.com/downloads/bin/teraterm_utf8-4.53.zip


#13

@ drmcghee - you can also try our legacy firmware tool for Spider, it is bundled in a zip file: http://www.ghielectronics.com/downloads/firmware/GHI_NETMF_Firmware_Updaters_legacy.zip


#14

Help!

Trying to update the firmware on a Spider from this…
Loader (TinyBooter) Version: 4.1.6.0
Firmware (TinyCLR) Version: 4.1.8.0
…to 4.2.

FEZ Config dies while uploading Firmware2.hex. I have tried many times and it always dies at the exact same point (about 60% on the progress bar).

Now, the version reads back as this:
Loader (TinyBooter) Version: 4.1.6.0
Firmware (TinyCLR) Version: Not available.

I have tried FEZSpiderMainboardUpdater.exe but that doesn’t work (I flip the last 3 dip switches on the Spider and hit reset, but the USB driver installation fails and there’s no way to talk to that board in that mode).

So please help. I’ve killed all optional processes on Windows (Windows 7 Pro 64 bits), and it looks like FEZ Config has a bug.

Thanks in advance – cheers!

Louis


#15

@ lsauve - please use the old updater, listed on support page, to update tinybooter.

If you have problems, start a new thread instead of replying to unrelated topic.

Welcome to the community.


#16

Thanks for the quick response Gus.

I thought this thread was related because the error I’m getting is this:
“Interrupt while deploying. Updating failed!”

By “old updater”, do you mean FEZSpiderMainboardUpdater.exe or TeraTerm? Other?

Thanks again,

Louis


#17

The spider updater.


#18

In the past I had some issues with updating my Spider. I has success using the old >NET Micro Framework Deployment tool. (MFDeploy).

Updated using USB EMX_EMX

See attached images. Better than words (I think)…


#19

Thanks Gus and Willgeorge!

I tried MFDeploy. Here is what I get:

Config.hex:
Dies right away:
Error: Signature check failed for file Config.sig

Firware.hex
Deploys fine but reports this error after signature check:
Error: Signature check failed for file Firmware.sig

Firmware2.hex
Dues at 60% progress:
Error: Unable to deploy to device

This is a brand new Spider right out of the box.

Louis


#20

Correction:
Dues at 60% progress
should read:
Dies at 60% progress

Louis