Main Site Documentation

Installation problems on Windows 7 (with all the updates and Service Packs)


#1

When I try to run the insatller for GHI NETMF v4.1 and .NET Gadgeteer Package Jan. 6, 2012 I get a Pop-up window containing the text "The folder path ‘My Documents’ contains and invalid character.

I have repeated the setup, as suggested, three times and get the same error each time. I am not sure what I should do now.

I have done a search on the forum for installation problems and the only thing I found was a conversation about installation problems on WindowsXP, but none of the suggestions seemed to apply.

I’m not sure what to do next.


#2

I assume your user name has some unicode characters which causes the “my document” to have unexpected characters.

What is your folder name? Mine it C:\Users\Gus Issa\Documents


#3

my user folder appears to be “C:\Users\SuperDave\Documents”. I don’t recall having this problem with the other version of the SDK installer. I have been a user for some time and have update with each new release ( and some beta release as well) and this has not been a problem before.

Same computer for the last 2+ years.


#4

Have you tried individual installer manually instead of running the package installer. This will tell us which one is not installing.

Do you have netmf 4.1 installed?


#5

yes I have NETMF 4.1 installed. (I just verified that to be sure)

I tried executing …\GHI NETMF v4.1 and .NET Gadgeteer Package\Installation Files\GHI NETMF v4.1 SDK.msi directly and get the same


#6

Dave, can I ask is this a “corporate” device at all? Any chance you have folder redirection turned on?


#7

No this is my personal computer.

I’m not sure what you mean my folder redirection nor am I aware of how to tell if it is turned on.


#8

A quick follow-up. I used the scripts from the downloads page and was able to install 4.1 on my work computer.

So there is something about my Windows 7 installation that is not allowing me to install the software. When I get home tonight I will attempt to install it on my Windows 7 Pro laptop.


#9

Super Dave, you’re not Huntsville are you? I have a good friend there that I haven’t seen in a while that I nicknamed “Super Dave” a long time ago… :slight_smile:

EDIT: Concerning your problem… You might try adding a new admin user to your computer and then login as that user and try the install. That might rule out any problems with security, etc. related to the specific folder Windows is trying to use by default.


#10

No not from Huntsville. Will try a second admin when I get home tonight.


#11

[quote]No this is my personal computer.

I’m not sure what you mean my folder redirection nor am I aware of how to tell if it is turned on.
[/quote]
In that case, you don’t need to worry. I had a theory that the installer may have been complaining about an inaccessable user profile because of the redirection, which was something I had seen on one of the SDKs when I first started Fezzing around 2 years ago - that obviously can’t apply to you though, and I have not seen it in the recent past.

One other thing to suggest, have you run chkdsk and seen if there’s any hint of corruption ?


#12

What about the other ones?


#13

I created a second Administrator account, and everything installed just fine. So it is something to do with my account and nothing to do with the installer( not that I thought it ever did)

Anyone have a suggestion how I can fix this?
At least I have a work-around to install the SDK.


#14

Can you move the files to a different directory, delete the directory, recreate it, then move the files back? Windows will likely prevent this but it’d be my first try.


#15

Just in case anyone is interested I have found the root cause. I have no idea how it got this way, but in the registry, where %USERPROFILE% should be, the registry contained “g:\user\Dave\My Documents”. Once I changed it back, I was able to install just fine.