Installation errors windows 8.1 and NET MF 4.3

Hello Forum, can you help please?

I have just purchased 2 Cerbuino Bee’s and cannot see them in device manager.
I am on windows 8.1 Pro N 64 bit with Visual studio 2013 professional.

I installed the software following the guidance here

I also followed the additional guidance for 2013 here

When I plug the Cerbuino in, the power LED lights up, but it is not seen in device manager.

When I installed the SDK using this NETMF and Gadgeteer Package 2014 R5.exe I get an installation error (see details below).

This is what I have tried:

  • Un-installed and reinstalled a number of times
  • Installed the packages individually (I cant find where I found the separate packages though).
  • Enabled windows 8 for unsigned drivers and reinstalled everything from NETFM 4.3 onwards.

Any ideas what I am missing?

The error at the end of the Log file from installation reads:
15D0:1220][2015-02-07T17:27:52]i319: Applied execute package: sam_ba.2.12.exe, result: 0x0, restart: None
[0BB4:0F2C][2015-02-07T17:27:52]i301: Applying execute package: DfuSe_Demo_V3.0.3_Setup_amd64.exe, action: Repair, path: C:\ProgramData\Package Cache\676712FC14BC24F61C8DB296CC501E08CC58392E\DfuSe_Demo_V3.0.3_Setup_amd64.exe, arguments: ‘“C:\ProgramData\Package Cache\676712FC14BC24F61C8DB296CC501E08CC58392E\DfuSe_Demo_V3.0.3_Setup_amd64.exe”’
[0BB4:0F2C][2015-02-07T17:28:36]e000: Error 0xffffffff: Process returned error: 0xffffffff
[0BB4:0F2C][2015-02-07T17:28:36]e000: Error 0xffffffff: Failed to execute EXE package.
[15D0:1220][2015-02-07T17:28:36]e000: Error 0xffffffff: Failed to configure per-machine EXE package.
[15D0:1220][2015-02-07T17:28:36]i319: Applied execute package: DfuSe_Demo_V3.0.3_Setup_amd64.exe, result: 0xffffffff, restart: None
[15D0:1220][2015-02-07T17:28:36]e000: Error 0xffffffff: Failed to execute EXE package.
[15D0:1220][2015-02-07T17:28:36]i399: Apply complete, result: 0xffffffff, restart: None, ba requested restart: No

@ BriK - did you execute the script in administrator mode?

is anything seen in Device Manager? An unknown device ? It is extremely unlikely that a device won’t show up at all, unless there’s a fundamental breakdown in the USB communication, so I’d try replacing the USB cable as a test.

I did run as administrator

Nothing is seen in device manager. However there is one unknown device, which I think appeared when I installed some IOT software for the Galileo. See image

I did try different cables and I plugged them into different USB ports on my PC

do you have another PC you can test these on?

At a minimum, without any software installed, you should get an unknown device in Device Manager if they’re working correctly and presenting themselves to the USB port correctly.

It may be possible they don’t have a firmware on them. Can you test booting into loader mode (I don’t have a cerbuino so can’t tell you how, but will help) . You may then see a “serial camera detect” device with a COM port assigned to it if the bootloader starts successfully. That will at least tell us that the device is responding appropriately.

1 Like

Thank you that solved most of my issues. :clap:

I plugged the boards into my windows 7 laptop with VS2013 professional, and nothing appeared in the device manager. So I installed everything on the laptop, I then updated the loader and firmware by following the guidance here
and here

I now have a working system on my laptop.

I wasn’t expecting the boards to be shipped without any firmware, especially as they are specifically targeted at .net MF.

Now back to my windows 8 system, I still cannot get this to work. In fact I get an application error whenever I try to run the STDFUTester (see image). I am going to roll back my windows 8 system and retry the install. I will add a progress update later.

@ BriK - I believe that error is caused by you not having the correct Microsoft Visual C++ redistributable version installed. I cannot recall which exact version you need (I want to say it is 2005), but if you look in the Windows Event Viewer, under Windows Log > Application, you should see an error relating to the dialog you saw. It should give you more information about which version you need.

Try to start the program and then immediately look in the event viewer so the error is right at the top.

1 Like

@ John - Thanks, I did need the Visual studio C++ distributable 2005. I installed from here:

I would have expected that to be a dependency of the installer.

So to get my system working;

I un-installed all of the .net MF and gadgeteer software then I rolled back windows to an older restore point.
After a couple of attempts at reinstalling the software along with the c++ re-distributable, I finally got the system working.
I then loaded the firmware onto my second device (as explained in my earlier post).

My windows 8 system is now fully working.

Thank you Forum for your help :slight_smile: