Initial Experience

Plugged in the SD, which I had prepared in advance, and then fired up the board. About five seconds later the red light came on.

I loaded a program to enumerate the mounted file systems and got a lot of info back. I need to study the output further to see if I can figure out what it all means.

I then tried the sample program for starting WiFi. I had a dongle that I used with a Raspberry Pi clone. The program stopped with an exception saying “check the ssid and password” when creating the Network object. They were correct, so I have to go back later and try other USB wifi dongles/adapters. Would be good for the community if members identify wifi adapters that have worked successfully.

*** Ordered two dongles which use the supported RTL8188 chip. I will check these out on Monday.

I then started a GPIO test program I developed, and I was able to receive an interrupt when pressing one of the buttons on the board.

Then it sort of got interesting…

I got out my loupe and looked at the STM chip on the board. I did a search and found out that the chip is a dual core A7 plus a M4 core.

Are both of the A7 cores already running, or is this a future feature?

When compiling and loading a program, I get a message from Visual Studio that it is taking more than 12 seconds to do something, and suggests that the Endpoint extension be disabled. But, everything still works.

So far, lots of fun, and seems solid… more to come

1 Like

We use the M4 to handle signal processing features. You could potentially load it with whatever you want.

I might be wrong, but the datasheet I looked at said the chip had two main A7 cores plus the M4.

I am going to do an experiment and see if I get dual core performance.

I wrote a small program which was able to run n-threads, each running the same compute intensive code.

At one and two threads the completion time for each thread was identical. At three threads and beyond, the completion time for each thread was almost identical, and proportional to dividing two processors between the running threads.

So, Domino STM32 is dual core, and Endpoint/.Net is utilizing both cores.

Double your pleasure… Double your fun…