In case your FTDI device stopped working

It could mean that the chip is counterfeit and latest Windows driver zeroed it USB PID.

So there is a work around:

Given some of the recent news on vulnerabilities in USB, it could also be that the zeroing out of the USB PID was done as a precaution to protect against potential hacks using the fake chips. To be clear, that’s speculation on my part, but I don’t know that it’s fair to characterize this as Microsoft “going after” consumers, but perhaps an attempt to protect them. I’d want more info before leveling such an accusation, particularly since there’s no obvious upside for Microsoft here in simply making devices inaccessible for no good reason other than the fact that they’re fakes.

@ devhammer - I think by “going after” the consumers they meant FTDI.

Could be. But again, they don’t offer much if any evidence that that was the intent.

Personally, I know I’m much more sensitive to the possibility of bad things happening with random USB devices that I might use, and if I found out that something I had that connects via USB was using fake chips, it would go in the trash immediately.

Is it possible that FTDI got Microsoft to do some dirty work for them and stamp out counterfeit devices just so that FTDI wouldn’t lose money? I suppose it’s possible, but seems to me that you could easily make the case that security is also an important factor.

Quick follow-up…found an Arduino forums thread on this, and it appears from what I can see there that Microsoft doesn’t have any direct involvement in this at all, other than providing the infrastructure by which FTDI is able to provide driver updates.

If, in fact, what happened is that FTDI reprogrammed the hardware of the counterfeit boards/chips, that’s arguably over the line.

I’d still argue that folks are better off avoiding counterfeit chips, especially for stuff that you’re connecting to your PC/Mac.

I am not sure if it is really “over the line”. They have the right to protect themselves.

If all they did is provide an updated driver that made the device stop working without reprogramming it, I think there’s zero issue there.

What’s not clear from anything I’ve read to date is whether the updated driver actually modified the hardware. IMO, that gets into a pretty iffy area. Not sure I want any third party to be able to disable hardware I’ve purchased because they claim some form of infringement on their IP.

For example, would it be OK if the MPAA or RIAA was able to remotely disable playback of certain media types known for piracy? I’m sure they’d love to do that, but I don’t think it would be legal or ethical (to be clear, I’m not a lawyer, so that’s simply my opinion).

It’s an interesting move, to be sure.

So it looks like there’s definitely reprogramming going on, at least based on the analysis linked in this tweet:

It would be one thing to (re-)write the driver such that it only works with genuine FTDI hardware, but bricking the hardware is beyond the pale.

FTDI’s suggestion that the use of the driver implies acceptance of terms that cannot readily be found and/or read prior to installation is bogus, IMO.

I’m a strong believer in intellectual property rights, but FTDI’s actions set a very poor precedent, IMO.


Sue the manufacturers, as well as those building devices using the counterfeits, but to punish the end users who didn’t know that there was such a thing as “FTDI”, that’s low.

@ devhammer - Yes, they said that in the original post that driver writes PID 0 to the chip.

Before seeing the code from your post, I thought that they somehow determine if chip is counterfeit or not. But all they do is just write 0 to a memory location. The operation is a two step for a legit chip and fails if it is done in one step. Apparently it works for clones.

I am more interested how many people actually suffering from that and what devices/manufactures got “caught” by the new drivers.

I’m sure FTDI doesn’t see it as “punishing” the end users, but it’s still a bad move on their part, IMO, as it’s plainly hurting their reputation in the Arduino world.

Sometimes you can win the battle, but end up losing the war.

I’m sure FTDI doesn’t see it as “punishing” the end users, but it’s still a bad move on their part, IMO, as it’s plainly hurting their reputation in the Arduino world.[/quote]

I’m sure not, but the affected end users will. It’ll be what people remember when they hear FTDI.

[quote]We appreciate your feedback, comments and suggestions.

As you are probably aware, the semiconductor industry is increasingly blighted by the issue of counterfeit chips and all semiconductor vendors are taking measures to protect their IP and the investment they make in developing innovative new technology. FTDI will continue to follow an active approach to deterring the counterfeiting of our devices, in order to ensure that our customers receive genuine FTDI product. Though our intentions were honorable, we acknowledge that our recent driver update has caused concern amongst our genuine customer base. I assure you, we value our customers highly and do not in any way wish to cause distress to them.

The recently release driver release has now been removed from Windows Update so that on-the-fly updating cannot occur. The driver is in the process of being updated and will be released next week. This will still uphold our stance against devices that are not genuine, but do so in a non-invasive way that means that there is no risk of end user’s hardware being directly affected.

As previously stated, we recommend to all our customers to guarantee genuine FTDI products please purchase either from FTDI directly or from one of our authorised distributors. Sales Network - FTDI
If you are concerned that you might have a non-genuine device, our support team would be happy to help out.

Yours Sincerely
Fred Dart - CEO

Happy I found this forum to understand my problem (FTDI USB to TTL not working) that started after Windows (7) update
For sure FTDI is punishing the customers!!!
How should I know if the chip is fake before I am buying the device?

Best wishes

Buy from a reputable supplier like Digikey, Mouser, Element14 etc and not one of the many Chinese sites.

Hi Dave

Now I am even more happy to find this forum. I should just write you an email from the start of my problems.
You are right, but you know that Element 14 and the others are shipping by UPS, DHL, etc’ and I am paying 2 to 3 times more than the price in Singapore. Also in DHL data base North Bali post codes are non existent, I have to pay additional shipping for a local shipping company from Denpasar to here.
Luckily FTDI are not the only one producing such product and sgbotics are shipping with registered posts, much cheeper :slight_smile:

Best wishes

Hi Joe, good to see you on here. You should check out the NETMF stuff whilst you are on here. It’s really cool to work with and the folks on this forum are an ace bunch and very helpful.

I replied too so you link will be visible and newbies are not allowed to post as we have had too much spam here. That link is a good one for me. You should check out Digiware in Surabaya as they have low cost shipping and they are excellent customer service. I’ve been using them for 10+ years since I came here. You can even order something that is only a few thousand Rupiah and they will ship it. I’ve paid more for shipping once just to get a part I needed. The don’t care. They will process it.

Thanks for the advice’s Dave
Will take a look at NETMF

Best wishes

I am emailing with FTDI:
Dear Mrs/Sir
I have a USB to TTL device using FTDI chip FT232RL. On the chip is also written 1213-C and CN480661
Everything worked fine until I made a Windows update (Windows 7)
What I am getting now is not what I am sending:

  1.   Tested by short circuit TX & RX on the TTL side, sending from the PC (hex) 55, AA, 00, FF and getting 00, 00, 00, 00
  2.   Tested with my application, my application sends   55, AA, 00, FF and getting 00, 00, 00, 00 on the terminal

Tried with different terminals and application, same results.
Please help
Best wishes
Hello Joe,
What version of FTDI driver are you using? Can you try our latest version 2.12.12?
Gavin Moore
Customer Engineering Support Team Leader
Hi Gavin
I done as you proposed, installed version 2.12.12
Connected the hardware, got answer installed properly
The problem persist.
I shortcircuit the TX to the RX
Sending 55,AA,00,FF four times with big intervals
Getting: 44,45,56,49 then 43,45,20,46 then 4F,55,20,46 then 21,20,00,4E
Connected to the target that sends 55,AA,00,FF every 5 seconds,
getting every 5 seconds 4 bytes with random data instead of 55,AA,00,FF
I was told on a forum that the FTDI chip on my hardware may be fake:
Forum | In case your FTDI device stopped working - GHI Electronics
Forum | In case your FTDI device stopped working - GHI E…
Reply #4 — Posted 1yr ago
View on www.ghielectronics…
If it is true, fighting the FTDI customers instead of the fake chip manufacturer is a bad solution.
Personally, I spent 3 weeks for nothing (it cost me dare) trying to figure out the problem until I found the above answer.
So I bought a USB to TTL converter based on an other manufacturer chip, also much more cheep. Worked with FTDI based devices for many years but you give me no choice and I am changing to an other manufacturer.
In my opinion, you will lose many customers because of your approach to fight the customers and not companies that are copying you products
Best wishes
WAITING FOR FTDI ANSWER, will post when will get

Getting: 44,45,56,49 then 43,45,20,46 then 4F,55,20,46 then 21,20,00,4E