Main Site Documentation

I think my Hydra is probably bricked


#1

Hi everyone,

I’m pretty excited to be getting into Gadgeteer development, my brother (who lives in another city) is always interested in doing a bit more with his circuit boards, and since I’m a c# programmer as my day job, these things sounded too good to pass up.

So I bought two Hydras, one for him, one for me which arrived yesterday. I made my own “Hello World” Equivalent using an OLED, then moved onto the ENC28 Ethernet Module which is needed for the first project and I summised from reading around the forums that I needed to flash the firmware to enable this module.

I added the SD Card module, and placed boot.bin on an SD Card and booted he Hydra with it. After waiting about 2 minutes I reset the device and then I could no longer do anything with it. Pressing update resulted in a message saying the device was not responding.

In device manager, it was showing as a ChipworkX Tinybooter firmware updater (or something to that effect) on COM3. I hooked it up to a different USB port and it became COM4, but I was unable to ping it from the flash interface or the MFDeploy application (on serial COM4)

I then tried using the command line tools “UpdateFEZHydra.bat” but again, there was nothing responding at the end of COM4. I’ve switched Reds and SD Card and attempted to start the process again, I’ve changed computers and attempted the upgrade on another machine.

Finally, I left that one over night and now it doesn’t even show up in device manager.

Anyway, so that one is probably stuffed and I took a look at the second board.

The first time I plugged it in, I tried pinging it from the Hydra upgrade and it left a message saying I had more than one Hydra plugged in (which I didn’t) so I restarted the machine which fixed that. I used a different SD Card and this time I got past clicking on the Upgrade button and it uploaded the files, then it never returned from “Waiting for your device to restart”. I left it for about 5 minutes and when it came back, restarted the device myself which didn’t help either. Having said that, at least it was now appearing as a GHI .NET Micro Framework USB Debugging Interface.

Except that none of the tools work when attempting to ping or deploy to it, everything just freezes.

So I’d like to ask if anybody else has had any experience with these issues before and if they have managed to get around it.

Thanks everyone,
–Steven


#2

You can probably bring it back to life. First of all, we do not want it to show as “ChipworkX updater…” in device manager. Do go to device manger an uninstall the driver and select “delete files” option when you uninstall them.

Now, rest hydra and windows will look for driver. You should be internet connected and windows will find “GPS device…” driver and load a new COM port in device manager. If windows asked, let it go online and search for driver automatically.

Once you have it up, you now have a blank device. Follow the instructions on wiki right after erasing the firmware.

Welcome to the community.


#3

I can tell from the scenario you are explaining that you got several modules on the hydra the withdrew much power (like Ethernet ENC module) to the degree that the USB port of your PC will not be able to keep the required power so the system goes unstable.
I suggest that you either connect the USB directly to PC USB port that provides more power you use a good powered USB hub. Or get USB client DP module that connect external power to the system.


#4

Hooray! My Hello World boots again! You guys are legendary.

A couple of notes for anybody else, if your device isn’t showing up in device manager, make sure you unplug everything that isn’t needed for the firmware update… (I must have had my screen plugged up to the wrong port)

Secondly, it says quite clearly on the Wiki, when flashing from the commandline, specify your COM port in lowercase[italic][/italic].

I’ll try again with the second Hydra when I get home later tonight. Thanks again!