Main Site Documentation

I can not run my project


#1

Hi gents,

I have " FEZ Cerbuino Bee " And I worked all settings ,

but I have some problem with " debugging "

If I want debug my project he working that few Second and he out the debug ???


#2

Hi, welcome to the comunity.

This might be a Problem with the USB Driver.
Please open the Output in VS before you start debuggung so you can see what’s in there.


#3

Thanks Mr. Reinhard Ostermeier

I will did that and I have this problem

pic1 after the building

pic2 after the debugging


#4

yes I did

BTW The same project worked Correctly in anther PC ??


#5

pic1 After building

pic2 After Debugging


#6

Does this mean the window?


#7

Yes.The same cerbuino bee I used with anther device .

and I use the USP device


#8

O.K

now it’s working :slight_smile:

but in the pic,
If I choose ( continue ) he is not working :frowning: but if I choose ( break ) and debugging again he is working done :slight_smile:


#9

If you choose continue, you’re telling the app to try to move past whatever the exception was; in most cases this terminates active threads and it looks like the board is “hung”.

If you choose break, you’re telling the running app to halt where it is and give you debug access again. The app is stopped, but in a controlled way.

So what you need to do is figure out why you’re generating an exception, or use a TRY/CATCH block around whatever you’re doing, so the exception may not kill the app

What is this app doing? Where is the exception thrown, at what point in your code? Is this a “blink LED” type app - given that these are your first few posts here, we’re expecting that you need to start simple so going back to basics in your code will help you understand some of the foundation steps before trying to do complex things. http://www.ghielectronics.com/support/dotnet-micro-framework has a great set of getting started info.


#10

BTW , the seam project and seam board working in anther PC correctly

I think I have some problem with hardware ?


#11

no, not necessarily.

Do you have exactly the same firmware/sdk versions installed on each pc? Do you have exactly the same drivers installed? Check device manager on each. Plus do the pc’s have usb3 ports at all? Probably you have a power issue more than a hardware issue.


#12

I think I have the same firmware/sdk versions, because I downloaded in the same page !
http://www.ghielectronics.com/support/dotnet-micro-framework

I don’t know about the drivers I took a screenshot for all of them .

pic 1: for another PC "Actually " the Laptop
pic 2 : for this PC


#13

look in the release notes file in he c:\program files\ghi etc directory, and make sure its the same version for both!

and when I was talking about drivers, I meant for your Fez device. Plug them into both PCs when you capture device manager pictures.

and USB3, you should check the colour of the tongue in t port itself and check the manufacturers website to confirm if you do or don’t have USB3.


#14

Hi Mr. Brett

I looked the c:\program files\ghi , its same version for both .

I capture device manager pictures after I plugged the drivers ,all of them .

USB3 I think I don’t have USB3 in both my PCs :frowning:


#15

ah you’re right I didn’t see the ghi device in the screenshots…

so please test this. On the PC that “works”, deploy your app and make sure it runs as expected

Then, disconnect it and reconnect it, without attaching the debugger, and make sure it continues to work as expected. If you need to attach a debugger to see whether it is working correctly, use MFDeploy and attach (I suggest adding a thread.sleep of 5 secs at startup of your app to allow you time to do that)

Then, disconnect it from that PC and connect it to the other PC, and make sure that the app then works as expected. Again, use mfdeploy if you need to attach a debugger. Now, a working device at one location should keep working if nothing else changes. If you have a power issue then that might show up as a behaviour change.


#16

What do you mean ( attach a debugger ) ?


#17

I mean open MFDeploy, set connection correctly as you require, and connect to the debug output.


#18

how can I found ( MFDeploy ) ?


#19

C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.2\Tools


#20

Did you mean this program in the picture attached?

can you tell me how can I use that ?