Main Site Documentation

I broke it


#1

I made a post and now I get the following error.

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@ ghielectronics.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


Apache/2.2.16 (Unix) mod_ssl/2.2.16 OpenSSL/0.9.8e-fips-rhel5 mod_bwlimited/1.4 Server at www.ghielectronics.com Port 443


#2

@ Cowboy - I wouldn’t go outside for a couple of days.
Or you might be “surprised” by a swarm of flying monkeys.


#3

@ Architect - Is this the 13th?


#4

@ Cowboy - in the meantime, if you want we can continue working your problem here. Did you get to start over or are you posting from the airport?


#5

@ ianlee74 - I am currently setting up my laptop which is virgin. So it will take me a while.

I did start over and got to the same point of it saying duplicate devices. I had unplugged all usb devices except for the mouse. So I am going to give it a try on a laptop.

Thanks for asking. I will post here the results of that adventure.


#6

@ ianlee74 - Ok, made some progress.
After building the laptop I ended up with the exact same situation.
So I decided to download the GHI sdk 4.2.(I would like to talk to someone about the revision numbering) and install it.

Started from the beginning again and now I can run “FEZ_Config_v013.exe” and it will connect and ping.

But trying to update the firmware I get “There is no Hydra connected.”

I justed ping it and it showed “TinyBooter”

I got the same thing on the laptop and I moved back to the desktop where I have a powered hub. Same result.

Friday night. I think I’m going to go have SUHI and think about this later.


#7

Did you ever actually get the TinyBooter updated to the latest version?


#8

I think so. Is there a way to tell?


#9

If you ran UpdateFEZHydra.bat and it finished and popped up a long log file and there were no problems in the log then it finished successfully. Did you get that?


#10

Yes, and I just ran FEZ Config and this is what I get when you hit the Device Version

Connecting to device…FEZ Hydra_Gadgeteer
Loader (TinyBooter) Version: 4.2.5.0
Firmware (TinyCLR) Version: Not available.


#11

I’m holding my breath. I hit Firmware Updater and it looks like it might be working.


#12

Is setting there with

Device will be updated automatically! DO NOT disconnect or turn off the device!

Connecting to device…
FEZ Hydra_Gadgeteer is connected
Please wait while rebooting in TinyBooter mode…
Found TinyBooter version: 4.2.5.0

Updating Firmware. Please wait…
Deploying C:\Program Files (x86)\GHI Electronics\GHI OSHW NETMF v4.2 SDK\FEZ Hydra\Firmware\Firmware\Ethernet\Config.hex… successful!
Deploying C:\Program Files (x86)\GHI Electronics\GHI OSHW NETMF v4.2 SDK\FEZ Hydra\Firmware\Firmware\Ethernet\Firmware.hex… successful!
Executing application…

and it shows 100% but saying “Executing application…” I wonder


#13

YEA! It works!! I’m blinking the LED.

Thanks so much for your help! I will find a way to pay you back.

I am going to write this up. There are to many gotcha’s that aren’t documented right.

I am wondering why the firmware deploy is having so much trouble connecting.

Again thanks.


#14

Fantastic! I’m glad you’re rolling. All you owe me is another post when your project is done. :wink:


#15

The real killer with this issue is the socket 14 pin 9 vs socket 3 pin 8 and the fact that SDK 4.2 vs SDK 4.2 DATED 4/30/13.

This really needs to get to a real revision numbering system.

Something like 4.2.0.0 - 4.2.0.1 and so forth. Then us dummies would realize that we have the wrong version.

The first thing every one ask is what version are you running. Whi. 4.2.
Not complaining just stating fact that needs attention. If I can be of help in developing documentations I am available.

Thanks again!


#16

your suggestion has been noted !! I’ll add a item to my future SDK discussion list on Monday when I’m in the office.

[quote]This really needs to get to a real revision numbering system.

Something like 4.2.0.0 - 4.2.0.1 and so forth. Then us dummies would realize that we have the wrong version.

The first thing every one ask is what version are you running. Whi. 4.2.[/quote]


#17

@ Jeff - Seriously, I am more than willing to help write docs or review them if you would like.


#18

Could I get someone to delete the entry I posted that is keeping me from getting to “mypost” its in General Discussion - Hydra will not ping - Page 2. See the top of this Discussion.

Thanks


#19

For convenience

https://www.ghielectronics.com/community/forum/topic?id=12356&page=2


#20

@ Architect - If I click on the link you gave me I get the following

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@ ghielectronics.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


Apache/2.2.16 (Unix) mod_ssl/2.2.16 OpenSSL/0.9.8e-fips-rhel5 mod_bwlimited/1.4 Server at www.ghielectronics.com Port 443