Main Site Documentation

Hydra Update


#1

Hi,

I have recently updated to the newest versions on my PC, no problems there and I’ve update my FEZ Spider which is working, love the new config it works a treat.

However, I can’t update my Hydra. The config recognizes it, but it fails to ping. There are no errors in the device manager it is recognized.

I’ve had a look on the forum but not found anything - am I missing a step?

I have so far found the Hydra to be the best board so I’m keen to get it up and running again.

Thanks in advance.


#2

@ shapingstuff - With FEZ Config, what is the output if you press “Check device for update” on the connection tab?


#3

Are you running a VM? Are you using a USB3 port on the new PC?


#4

Hi Both,

It was plugged into USB3 but I tried it in the other USB2 socket and it’s still not working. I’m not on a VM, I’m running in Windows 7.

Failure - Device is not connected or not responding. Though in the config it is there as a recognized device to select in the USB menu.

It just struck me as funny because Hydra has always been the most robust for me and rarely holds up when uploading code.


#5

@ shapingstuff - if you can, please post some screen prints of what is going on so we can diagnose the problem.


#6

Hope these help - anything else let me know - thanks.


#7

Can you add one from before you try to update the firmware (should show Hydra’s name in the field next to USB) and the details from the other two tabs of the driver.

(faint memory here: wasn’t there some reason about NOT using winUSB driver on Hydra?)


#8

@ shapingstuff - did you recently update the firmware on this Hydra that is failing?


#9

I recently re-installed everything so I was on the new GHI software for Visual Studio. I have only updated the Spider board I have, I have not been able to do this one at all since re-installing everything - actually it was working fine before the new install so the driver maybe, has this changed?

I have added the extra screen shots though I cannot see any tab relating to the driver.


#10

@ shapingstuff - have you only tried to ping it in FEZ Config?


#11

The (original) 2nd image you showed, has three tabs and you’ve only showed one of them…


#12

I have tried to ping the board in MF Deploy but get the same response.

“Pinging… Error: No response from device”

I have also attached the tabs in the device manager which suggest the driver is working fine.


#13

@ shapingstuff - Try to place the board into TinyBooter mode to see if the Hydra will ping in MFDeploy. To do this you will need to ground pin 9 (easiest way is with an extender board) and hold it for a second or two while rebooting the board.

If you do not have any kind of breakout module here is a reference to the socket pins: https://www.ghielectronics.com/docs/120/gadgeteering-hardware#1131

If you can get the board to ping, use MFDeploy to reload the firmware but make sure it is the non Ethernet firmware or the board will appear to be locked up as you are describing now.

If this does not work, try to do the manual update found on this page: https://www.ghielectronics.com/docs/125/loader-tinybooter-update-fez-hydra