Main Site Documentation

Hydra unseen after update try


#1

Running Windows 8 64bit
using Hydra with USBClientDP, sdCard & display_T43. Using external 2A power supply.

Hydra was working (except for debug in some cases). I could download and run programs.

Uninstalled old drivers.
Down loaded NETMF Gadgeteer Package 2013 R3 and installed it.
FEZConfig said TimeCLR and TinyBooter needed updating. So I pressed the firmware update button. It started and then at some point said it could not connect to the Hydra.
Now Windows does not recognize Hydra. I am unable to connect to the Hydra and thus unable to update it in anyway.

So how do I fix this?


#2

Unknown Device


#3

Did you selected (default) the WinUSB driver during setup of the new SDK? If i remember well Hydra does not work with WinUSB


#4

And uninstalling the old driver manually is very important as noted in the news post and mentioned in the installer.


#5

@ dcas -

[quote]
FEZConfig said TimeCLR and TinyBooter needed updating. So I pressed the firmware update button. It started and then at some point said it could not connect to the Hydra. - See more at: https://www.ghielectronics.com/community/forum/topic?id=13709#sthash.SZo04ouI.dpuf[/quote]

FEZ Config now only supports to update TinyBooter on G120, EMX

For Hydra, G400, Cerberus it does only update firmware

For manually on Hydra: https://www.ghielectronics.com/docs/125/loader-tinybooter-update-fez-hydra


#6

Looks like people are having problem with that. May be a more detailed step by step instructions on how to manually re-install the driver would help?


#7

Before installing R3 I did uninstall the drivers.
The installer would not allow me to use the WinUSB drivers.
So, as of now what is installed is the GHI NETMF USB driver set that came with R3.

I uninstalled these and reinstalled using the setup.exe that came with R3 and still no go.

I think FEZConfig started eraseing and did not reprogram on the Hydra.


#8

What is installed right now on Windows is GHI NETMF USB.

What I started to do was follow the instructions on ‘Loader (TinyBooter) Update FEZ Hydra’ at https://www.ghielectronics.com/docs/109/usb-drivers-choices-including-winusb.

I put the program boot.bin on an SD card and tried it but it did not work. Then I saw that the card had to be less then 2GB and my one and only card is a 2GB.
I have to go some 45 miles one way to a Radio Shack and further for a Best Buy but that may be my only choice.
I just hope that someone still sells cards less then 2G.


#9

I’m not sure what is going on.
The instructions said 2GB was ok but a few lines later said it had to be smaller then 2GB.
In any case, my 2GB card (which was working in a loaded program) seems to not be working in trying to erase the flash. The card only has the one program boot.bin.
The Hydra still boots up in the last program downloaded to it and Windows still does not recognize the board.


#10

Good News… I got the board to work again.
It now has the latest TinyBooter and TinyCLR.

I had to short pins 8 & 10 on socket 3 together for 5 seconds on power up to put it in some mode where a batch file provided in the SDK loaded TinyBooter. Then I used MFDeploy to load TinyCLR.

Now I can load my projects again.

Life is good again.


#11

I do have same behavior, and without really to understand why the device becomes visible to windows if an ENC28 Ethernet module is connected to socket 4 (not socket 3)


#12

@ dcas - I’m wondering if you do have ENC28 module connected to your board? And if to what socket


#13

I do not have the ENC28 connected as I have not bought one yet.
I have the following connected: a display_T43, USB Client DP and a Micro SD Card.

I think FEZConfig messed up the Hydra trying to update TinyBooter and/or TinyCLR.
I know now that FEZConfig can not do that on a FEZ Hydra.
That should have been clearer in the instructions and FEZConfig should not have even tried it.

As of now, my Hydra is working and I am happy.


#14

@ dcas - Good to hear that you have your hydra working!

@ GHI the hydra documentation tells that ENC28 needs to be connected to socket 3, is that really true? My board won’t start when at 3 but will when connected to socket 4