Main Site Documentation

Hydra TinyBooter will not update


#1

I’m teaching a Gadgeteer workshop in a few hours and I have one Hydra (v1.2) that is refusing to cooperate (stage fright). I’ve tried all the tricks but cannot get the TinyBooter updated. Using the jumper on socket #3, I’m able to get a “GPS Camera Detect (COM4)” in Devices & Printers. However, sam-ba cannot find a device on COM4 when I run “UpdateFEZHydra COM4”. I’ve updated a couple other Hydras & Cerbs without any problems but this one is not happy. I’ve tried on two different computers with two different cables. Any other ideas?


#2

After fooling with this some and physically touching the components, I discovered that the power LED would go off if I touch it just right. So, I believe I have a problem with the board. I’ll try to re-heat some of the components tomorrow night and see if that fixes it. If not, I may have an RMA. I’m still puzzled at why it shows up in Devices & Printers but sam-ba can’t detect it.


#3

I bet it is just fine. I have seen similar samba issues. Maybe related to G400?


#4

I think maybe the problem is related to my Macbook Pro. I was totally unable to demo anything from the laptop during the presentation a couple weeks ago. Humiliating… So, when I got home I re-installed everything and it all worked fine. I’m leaving in a few minutes to go do a private intro to Gadgeteer workshop for a company and now I’m having the same problem! I’ve just reinstalled everything again but it still doesn’t work. When I try to run sam-ba through the UI, it finds the device but when I try to connect it gives the attached. This sounds like perhaps a TinyBooter code problem? I don’t know much about sam-ba. So, I could be totally off. I’m starting it w/o any arguments. Just double clicking sam-ba_cdc.exe and using the GUI. Hopefully, I’ll be able to get everything working on someone else’s computer when I get there. Uggg…


#5

@ ianlee74 - are you running a VM or bootcamp?


#6

I have a bootcamp partition that I boot directly to. Once I got to the workshop, I discovered that everything worked fine with my Cerbs. The problem seems to be limited to the Hydras. I used to have no problems with either until lately. So, I think the problem was introduced in one of the last 3 SDK releases. I’ll do some more tests tonight if I get home early enough.


#7

After not being able to use my Hydras for 4-6 months, I have finally solved this riddle!!! Apparently, either UpdateFEZHydra.bat or something lower down changed a while back and it no longer wants “COM4”. It now wants “com4”… After making that one simple change, I’ve now been able to update TinyBooter and deploy to these boards again. Just in time for our Maker Faire this weekend. Hallelujah!