Main Site Documentation

Hydra not responding


#1

I was working on a new menu program and my Hydra became unresponsive when I downloaded the program. The N18 display is all white and the Hydra can not be detected. I performed the reload procedure grounding pin 8 and the unit appears as GPS camera detect COM12. I then ran the UpdateFEZHydra.bat com12 and I get a line that says ACCESS DENIED. I have waited 4 minutes and nothing happens. I am not sure after the com appears if you leave pin 8 grounded. I have tried it both ways and same results. Any ideas?


#2

hi CDR114 and welcome

ACCESS DENIED means you’re likely not running as an administrative user. Please start the command prompt as an administrator before you run the update batch file. You should see the difference then. If we need to troubleshoot further you are probably going to need to describe your OS and your SDK versions so you get more specific responses.


#3

Thank you that worked. It is windows 8.1 and my login is as an administrator, so I assumed that the command line ran as administrator. Bad assumption.


#4

that’s awesome. now time to build awesome stuff with your Hydra :wink:


#5

Working on a program that interfaces sports timers to a led sign controller for displaying timing results on a P10 LED sign board. I had a quick mockup working, and I am now working on a more complete program. Once again thanks for helping me out.

By the way, the problem was that you can’t create a bit map of an empty string. The program was sending a blank line to the N18 display, because there was no data and had the string variable had a value of “” and this made the Hydra mad! I changed the program to check for empty strings and inserted a blank thus the string variable had a value of " " and everything works. I need to add exception catching to the method in my program that creates bit maps for the display.