Hydra interrupts - need you help


I have project i wrote for simulate fast protocol using Hydra. I am starting with .Net and after that going to RLP and run in C code.
when I started this project i saw that Hydra had a short delay from time to time and i disabled AIC interrupts (*AT91C_AIC_IDCR = 0xffffff;).
It worked fine till last week, when i upgraded my environment to 4.3 (it was 4.2 till now).
Using the same code in manage(.net) and unmanage(RLP) i see short delays in hydra.
i am using same physical devices - led, usb serial, etherenet and button, but for some reason it looks like in 4.3 the framework enables interrupts that wasn’t there in 4.2

Anyone have idea how can i disable new interrupts? maybe its other issue that came in 4.3…
I really dont know what to do with it…

@ shm3 - What do you mean by short delays?

I saw delay that occurs each ~500. each time is for few milliseconds.

Did you try to load the 4.2 firmware to verify that the delay only exists in 4.3? I can’t see where that delay would come from. Not sure!

Yes i tried it lot of times.
My suspect is that in 4.3 managed code enable interrupt that was disable in 4.2 and it causes to this delay.

@ shm3 - If you take out networking completely, does the issue persist?

I can try it. the only different i can see between 4.2 and 4,3 is the ethernet device. in 4.2 i didnt add it in schematic. in 4.3 i have it like i have all other devices.

Do you know if Ethernet device register to interrupts? if yes - which?

@ shm3 - It only uses one regular GPIO interrupt.

can you give more details:
Which interrupt and how can i disable it in RLP?

@ shm3 - It’s pin 3 on the socket, but it is required for Ethernet to function so disabling it really isn’t possible if you use Ethernet in your solution. 4.2 also had the same interrupt enabled when using Ethernet though.