Main Site Documentation

Hydra I2C not working


#1

Do am I the only one unable to play with Hydra I2C socket? My gadgeteer project freeze if I try to read byte on my PCF8574. I’m using latest firmware (24th feb 2012).


#2

Make sure you have the latest firmware. If you still have problems, please provide a test app showing the issues.


#3

What is the best way to know it for sure?


#4

The FEZHydra version not supposed to be 4.1.3.1?


#5

Yes


#6

So I have uninstalled all GHI product from my computer, downloaded the SDK found here :

http://www.ghielectronics.com/downloads/NETMF/GHI%20NETMF%20v4.1%20and%20.NET%20Gadgeteer%20Package.zip "

Installed all the things and I do not have the good version when I create a new Gadgeteer project. What am I doing wrong?


#7

Did you try either creating a new project or removing your references to the GHI libraries and then add them back?


#8

When I checked my PC by adding references on an existing project (non Gadgeteer project) I only see 4.1.1.0 on the Hydra component, and 4.1.2.0 on Spider. So I don’t know that you have a problem from that perspective! (I have the RELEASED version of the SDK pack, not the beta version that was on offer prior to the release)

Edit:

Thinking about this a bit more, do you know that the I2C Device is working correctly and connected correctly? Did you have this working on a previous firmware version, and the firmware is the only thing that has now changed? Perhaps you can locate the older version and confirm that it still works


#9

Everything worked fine with the beta version. Unfortunately, I have deleted the beta files from my computer. Do someone have the beta version prior to 24th february release available somewhere I can download it?

Edit :

The I2C device work if I use another XY socket with a software implementation of I2C.


#10

Do not connect anything and run a simple i2c transaction. What happens?


#11

A write does nothing. (Verified by a scope on both SDA and SCL pins.
A read freeze the board (And Visual Studio if I am in debugging mode).
I dowloaded the source from gadgeteer to see where the code freezes in Gadgeteer dll and I found a line where the code jam. I’m not at home but as soon as possible I will give you the exact line.

Is it really impossible to get the beta version, because I really begin to think i’m crazy :o

(I’m pretty sure I have the latest firmware and SDK because before the OLED display did not work, neither USB connection (3Ghz CPU problem))

I can give a zip files of my code to someone if it could help (Just give me a way to do that)


#12

Please use I2C directly, no gadgeteer and et us know if it is the same. We will test on our end.


#13

If I tell you that my device adress is 0111000 could you give me a snippet of code to send a write of 11111110?

I’ve tried the EEPROM sample from wiki but no success. I’m not sure to know how to address pins without gadgeteer. I would like to use Hydra socket 6 for example.


#14

Jango,

I just tested the the first program here: http://wiki.tinyclr.com/index.php?title=I2C_-_EEPROM on a console app on the latest firmware 4.1.3.1. My setup is just the Hydra with a DP module on socket 2 connected directly to the computer and I get this result:

Waiting for debug commands…

The thread ‘’ (0x2) has exited with code 0 (0x0).
Register value: 0
The thread ‘’ (0x1) has exited with code 0 (0x0).
The program ‘[3] Micro Framework application: Managed’ has exited with code 0 (0x0).

Can you give us the version number on the board?


#15

On the board it is written Rev 1.1

And this is a normal result or not? With the same setup I get the following messages in the output window :

////
The debugging target runtime is loading the application assemblies and starting execution.
Ready.

Done.

Failed to perform I2C transaction
Waiting for debug commands…


#16

When you run the the first program of the I2C example, what do you have attached on your board? Try to only put the SP or DP module on and run the code to see what happens.


#17

This is exactly what I did!


#18

Do you have any of the Seeed Modules that use I2C, like the Barometer, acceleration, Gyro, or Compass? If you do, try one of those on the Hydra. I have tested those using the example program that is on codeplex. If those do not work then perhaps there is a deeper problem on your board.


#19

Unfortunately, I do not have any of those modules. But I repeat, the beta version worked fine. I do not know why I have deleted the zip files because I could try it to verify I was not dreaming :frowning:


#20

That version was deleted as it was never an official release but nothing is changed on i2c IIRC