Hydra Firmware Update ERROR

While USB specifications say ports should provide 500mA, we rarely see a port that can actually provide 500mA. We always recommend the use of powered hubs or a power pack instead of relying on the USB power. Use a powered hub from a known brand, not a cheap hub. If your device has the option of using a power pack (for example the USB Client DP Module) then you can use a power pack instead. 9V 1A is typically recommended but check the bottom of the circuit board for printed voltage range. All power connectors on GHI products are 2.1mm with positive on the inside and negative on the outer ring.

Not using a powered hub or power pack can cause:
[ul]Unexplained behavior
Device does not function
Device functions intermittently
Device functions but network fails
Device functions but SD card fails
Device functions but firmware update fails[/ul]
(Generated by QuickReply)

Hello again, first of all I want to explain that all the unlucky things I had encountered during firmware update was worked out that because I did not installed 4th step in http://www.ghielectronics.com/support/dotnet-micro-framework which said optional. I strongly RECOMMEND every Hydra user to install also step 4.

However I couldnt solve my An error has occurred: Please check your hardware problem in VS. Today I bought an adjustable adapter which can give ( 3 - 5 - 6 - 7.5 - 9 - 12) V and 1A . I tried both 9V and 12V. I applied both usb and 9V adapter to DP module, however the problem still goes on. I also changed my system locale to English (which was Turkish) . But nothing of these steps figured out this problem.

What can you suggest me to do after these steps?
Thank you


i also having the some problem cannot update hydra firmware. Is compulsory to use DP or using SP is fine? Currently i’m using SP and trying to wire MISO and GND also not working. Any suggestion?

SP will work - I’ve done it several times myself.

When you do that, what is shown in device manager? That will identify what the PC things is connected and essentially what part of the boot process you’re operating in. To manually update Hydra, you usually see a “gps camera detect” device on a serial port, if you’ve used the jumper wire correctly. Here’s the link http://wiki.tinyclr.com/index.php?title=Firmware_Update_FEZ_Hydra

The device manager show unknown device. I have tried 2 different pc but both shows the same.

ok, so did you follow the instructions in bold in the thread that the download points to that says now point the device to the drivers manually in the GHI directory? http://www.tinyclr.com/forum/topic?id=9388

Yes, but error show “windows was unable to install your unknow device”.

can we have screenshots of the other tabs in that device’s info sheet? And tell us OS version, x86 or x64, whether you’re running in a virtual machine or bare metal, and if you have USB3 or USB2 connections. Another thing that is always worth trying is different USB cables, good quality ones that have baluns on them are often the best, and sometimes power supply can be an issue (so a powered USB hub is best)

Hi Brett,

The error message as attach and I also connect external power supply by tapping from Panda II. After that I try to wire between MISO and GND but not avail. It keep showing the same error.

FYI, I’m using Windows Vista and also tried using Windows 7. Not sure what is virtual machine or bare metal.
I using the cable that have the baluns which supply by GHI.

Are you using SDK released today?

How to check but I download the sdk last week. I just received my hydra for 5 unit but i have have this problem for this first unit. I worry to try this upgrade for other unit.

I have instal SAM-BA and the hydra can enable the com port but when i try to update it still give same error as i post earlier. What is the com port for hydraupdater use? My com port is COM11. Is that fine? Any suggestion?

How are you trying to upgrade the firmware? What steps are you taking? Plus download the latest firmware available here: http://www.ghielectronics.com/support/dotnet-micro-framework
It is the 3rd link on the page.

I am having the same trouble. I received my Hydra, and did the following steps.

#1) Installed VS2010 Pro
#2) downloaded and installed Microsoft .NET Micro Framework 4.2 QFE2 SDK
#3) downloaded and installed GHI Software Package v4.2 Nov. 29, 2012
#4) During the install of #3 it asked if i wanted to update the board. I connected the Hydra, got the good USB sound detect when i did.
Then i clicked update, it found the board started to erase then after a bit it heard the bad USB sound.
I then unplugged it and plugged it back in, same bad sound.
Did some searching and shorted pins 8 & 10 on socket #3 when powering up. Still bad USB sound.

So now what should i try?

screenshots of what device manager shows would be a great first step

What do you see under device manager? Windows should automatically detect COM port if you are connected to internet.

Here is device manager

Using powered hub? Tried different ports? Is it windows 8?

@ Gus, Powered Hub, I have tried all 5 ports, Win 7 Pro.
When i first plugged it in, it connected and teh updater program found it and it started updating. Seems when it was done and it re-booted is when everything went to pot.

Do you have a display on the board? You probably do not see anything since it is in boot loader. Have you tried reboot?