Hydra - Display TE35

I am using the Hydraboard and the TE35 display. Now I have the problem that I have only a black display. I tryed to configuration the display over the FEZ Config software. With that I make “Apply to device” and get the response that it was done successfully. But the display is still black. I powered the board over USB. The Gadgeteers Designer shows a Power Estimate from 268mA so I think it will work. Have anybody an idea what can be wrong ?

Looks like you are doing it right but have taken a look at the Gadgeteer for beginner’s book?

Hi Gus,
thanks for the tip I read this document but I can’t find the solution for this problem. I collect some interesting points from this document. Is it normal that the chapter 6 til 8 is missing ?
Can you give me a tip in this chapter I have to saerch ? By the way I have the problem that the board lost the USB connection to the PC every minute or so. In the first step I don’t want to use the touch so I only work with the simplegraphic class at first.

By the way I have the problem that the board lost the USB connection to the PC every minute or so. [/quote]

That’s likely a problem with the amount of power you’re drawing and resetting the device. You need a better power source !

I’ve had a similar problem with the board disconnecting & reconnecting which I traced to the Samsung Mobile USB drivers. If they are installed I get the problem, uninstall them and the problem clears. I’ve had this happen on more than one occasion.

Hi Sprigo and Brett,
I make a test with an external power supply and I have the same problem. It works always perfect until I connected the display to the board. I have also no new driver installed. The only change I made was to connect the display to the board. I’am still wondering why it doesn’t show anything :(.

I read the TE35 instruction, and there I found that a wrong configuration can occurs a restart of the board. Because the controller gives free the RGB Ports when he can’t find the display. So have I change any values in the FEZ Config when I use Hydra and TE35 ? I saw that the values in the instruction and the FEZ Config are different. What means the Pixel Clock Rate ? Is this Khz ?

So I’m testing a lot of things. After I make a reset of board I have solve the problem with ever rebooting. But the display still keeps black. I have done the following step:

  • Connecting module to the Board
  • Load the display TE35 in FEZ Config up to the board
  • Implemented the display in Gadgeteer Designer and load the program to write a text with the simplegraphics class.

Does anybody know what I can do to test the display. At the moment I think the display is broken.

You didn’t accidentally select T35 instead of TE35 did you?

Have you tried initializing the display w/ Gadgeteer project instead of FEZ Config?

Didn’t mix up R/B cables?

(I asked because I’ve done all of those myself :wink: )

I choose TE35. R/B cable are ok according to the Gadeteer Designer. I took the Display configuration programm that I found under Document/Graphic and put it into the “ProgramStarted” function. Put additional the GHI.Hardware.dll to the project. When I deploy it. But it didn’t run. So is ProgramStarted Ok or it is neccessary to put it into the SubMain() ?

Have you tried different cables? One of them maybe damaged.

Hi gus,
I tried out different cable and I have the same result. I have Load the display configuration with the FEZ Config to the controller. And when I deploy my program to the controller I got the following message:
Updating display configuration. THE MAINBOARD WILL NOW REBOOT.
Is it possible that the c# software overwrite the FEZ Config LCD configuration again ? How can I load the configuration over the c# program ? Must I overwrite the sub main() ?

If you are using Gadgeteer you don’t need to set the configuration as the driver ‘knows’ the settings for the GHI displays.

It might also help if you post some code showing the problem you are having.

here is the code. It is only a little test program.

public partial class Program
// This method is run when the mainboard is powered up or reset.
myClassSerialPort mySerialPort;
GT.Timer myButtonTimer;

     void ProgramStarted()
        myButtonTimer = new GT.Timer(200);
        mySerialPort = new myClassSerialPort(mySerialPort1);
        //mybutton1.ButtonPressed += mybutton1_ButtonPressed;
        mySerialPort.DataLogging ("1");
        mydisplayTE35.SimpleGraphics.BackgroundColor = GT.Color.Blue;
        mydisplayTE35.BacklightEnabled = true;            
        mydisplayTE35.SimpleGraphics.DisplayText("Hallo",  Resources.GetFont(Resources.FontResources.NinaB), GT.Color.Blue, 60, 60);

   //  void mybutton1_ButtonPressed(Button sender, Button.ButtonState state)
       //  mySerialPort.DataLogging("2");

So you have Blue text on a Blue background - that might be a bit difficult to see! I would suggest picking a different color.

you are right. That will not work blue and blue , thanks for that. But at first I have still the problem that the display shows nothing. It looks like it is turning off. That you say that the gedgeteer driver makes the configuration is a good point. So normally I can’t do much wrong. So I think the display may be is broken. I have no idea what i can do anything else.