Main Site Documentation

Hydra continuously reboots


#1

Today I had a strange trouble after adding this line to a very small Gadgeteer project:


display_N18.SimpleGraphics.DisplayImage(Resources.GetBitmap(Resources.BitmapResources.PriceScreen), 0, 0);

The Hydra continues to reboot and therefore I can’t be able to connect to the mainbord for erasing the application.
I tried to reset the Hydra, I also tried to power it with an external USB power supply… but nothing changed.

Then, I assumed that I may had damaged the Hydra with some ESD and I tried with another new Hydra, but the problem happened even with the new mainboard.

Therefore, I tried to reload the firmware following the instructions in:
https://www.ghielectronics.com/docs/39/fez-hydra-developers-guide

  • Grounded pin 8;
  • turned on the Hydra;
  • removed the pin connection
    and the Hydra was recognized as “GPS camera detect (COM10)”

Unfortunately my project is in VS2010 - NETMF 4.2 (for legacy reasons), but anyway, I have found the Loader in
Program Files (x86)\GHI Electronics\GHI OSHW NETMF v4.2 SDK\FEZ Hydra\Firmware\FEZ Hydra TinyBooter Updater

Running the UpdateFEZHydra.bat as Admin, it shows the error: “SAM-BA_cdc” is not recognized as an internal or external command…
then I added the line

[em]cd C:\Program Files (x86)\GHI Electronics\GHI OSHW NETMF v4.2 SDK\FEZ Hydra\Firmware\FEZ Hydra TinyBooter Updater[/em]

to the .bat.

Running the modified UpdateFEZHydra.bat as Admin, the result was:

-I- Waiting …
-I- TCL platform : Windows NT
-I- SAM-BA CDC 2.10 on : windows
-I- Retrieved arguments from command line :
-I- argv 0 : at91sam9rl64-ek
-I- argv 1 : TinyBooterLoader.tcl
-I- argv 2 :
-E- Connection at91sam9rl64-ek not found
-E- Connection list : com10

the only reference to at91sam9rl64-ek is a sub-subfolder:
[em]\tcl_lib\at91sam9rl64-ek[/em]
that contains 2 files:

  • [em]fez_hydra.tcl[/em]
  • [em]isp-dataflash-fez_hydra.bin[/em]

Now, the questions are 2:

  1. I’m wandering around chasing butterflies or this maybe the right way to resolve the “root” problem?
  2. If the firmware “reload” maybe the right choice, I have done some mistakes for the 4.2 firmware upload? (The Loader update procedure for 4.2 seems to be no longer available from Hydra resource page)

Really thanks in advance for any help and sorry for the very long post… :-/

Have a good day!


#2

The right way to address a problem like this is certainly to apply the firmware again, as it removes the misbehaving application. You may need to do that multiple times if you continue to deploy code that has unexpected consequences.

As to why your firmware update , I really can’t comment. The process you need to follow is still the same - use SAM-BA to deploy the loader, and then use Fez Config to deploy the firmware. From memory, some versions of sam-ba are specific about capitalisation of the COM port number, so you should make sure COM10 is still visible and try both upper and lower case COM to see if that makes a difference. I’d also recommend starting a new command prompt, as Administrator, and navigating to the appropriate directory and then running the script, you may see more detail / errors. The AT91… is the processor family used so is expected.


#3

Thank you Brett, knowing that the “firmware road” is the right one to manage the problem helps me! :wink:

I checked that COM10 is still available during the update process, but I didn’t care about com name casing… I’ll made some casing trials, thanks!


#4

YES! You got it, Brett! ;D

The COM port must be specified lower cased. :clap:

Thank you again and have a good day!


#5

high fives all round ! Time for you to go make something cool and share with us :slight_smile: :dance: _