Hydra bricked

Hi all,
we have recently ordered some new gadgeteer modules from GHI. Unfortunately, after plugging in the OLED module, our Hydra stopped responding (unfortunately, we did not upgrade the firmware to the latest version which supports the oled).
We tried reflashing the firmware several times both, with the sdcard and with wiring the pins. However, in neither case the board responded. No USB-device is visible on any of the two computers where we tried that.
LEDs on the client DP and on the mainboard are illuminated, however, a connected display shows just a white screen.
Any idea what to try next?
Thank you in advance
Bernhard, Lukas


Try the usual:

-Different USB port
-Powered USB hub
-Different USB cable
-Another PC

A white screen on the cobra for me usually means not enough power connected to the device.

Have you tried flashing it without anything connected?

Thank you for the quick replies.
Already tried different USB ports on different computers. USB cable works fine (also the standard USB port we use) with our other gadgeteer boards.
There is nothing connected but client DP when we tried to flash it

If non of the above helped…
plug the CAMERA Module ( if you have it) directly to the DP USB and to the PC and see if your PC detects the camera… this would make sure you have a working DP module.

and one more thing: make sure you do not have anything plugged in to Socket 13 …


Try connecting the Hydra and opening MFDeploy. If it shows up try doing a reboot and stop tinyclr (it’s in the menus) then erase application. From there you should be able to get it to respond to a firmware update. You can also try doing some debug lines to see if hydra is responding. Perhaps it’s the LCD module that’s at issue.

Hi bedieber,

Welcome to the community.

Can you be more specific as to what you mean by wiring the pins? Can you describe the process you took to try to reflash the board?

I followed the guides for firmware update on hydra. I tried first with connecting the SDcard module and putting the boot.bin onto the board like I did during the last firmware update.
Then I tried the second way by placing a wire between pins 8 and 10 on port 3. No reaction either.

My problem is, that the hydra is not visible as an USB device, so neither MFDeploy nor the update software recognize it.

@ Bedieber, try this procedure … may be more lucky …


Thank you dobova,
tried that already. Just tried it again and in the best case the board shows up as unknown device, in the worst case, it doesn’t show up at all

@ bedieber
Be aware: are you sure that boot.bin is on a small capacity SD ? I got a problem few month ago due to sd not compatible. I use now a small 256k old SD for Hydra boot.bin

Looking in windows device manager you don’t see any port with “GPS something” ?

I use a 16MB (yes, M) card :wink: The card used to work
no gps something, no device at all. At best an “unknown device”

EDIT: sorry 16Mb must be ok. I read too fast …

Hi bedieber,

Do you have sound capabilities on your PC? If so, does any USB sound happen when you plug in the Hydra?

If it shows up as Unknown Device go in to device manage and right click the unknown device item. Select properties. On the second tab there should be an option to remove driver. I know it doesn’t sound like it makes sense but uninstall the driver even though there isn’t one and then try plugging it in again.

I’ve had this happen a couple of times.

Just to make on more test:

  1. detach hydra from USB and open device manager.
  2. in device manager menu, choos view -> hidden device
  3. go to and open the tree under “Ports (Com and LPT)”
  4. look there if you can find “GPS Camera detect (COMxx)” items.
  5. if found, destroy it : right click and disinstall all GPS Camera driver found
  6. better to make a windows reboot now
  7. after reboot, with system running, attach again Hydra and see what’s happen.

Just to ease your mind…
we haven’t encounter a Bricked GHI Board YET… so hang in there it’ll run eventually.

Hey All,
thank you for your many suggestions. Still, I’ve had no luck.
The device is still not showing up at all when I just connect it normally (Tried it on three different PCs, one even without any Gadgeteer SDK, no reaction there either).
When i connect Pins #8 and #10 on port 3, it at least shows up as unknown USB device (not as COM device). However, no uninstalling or other action seems to work.

Anything else we could try?

One other thing you could try is to switch the cable from another module to the power module to see maybe if it is a bad cable connecting the power module to the mainboard.

Already tried it with different cables and two different ClientDP modules