HubAp5 and Glide


I have come up with a problem.Somehow my projects stopped working for some reason (it told me i was missing an assembly reference ,and some BIN files could not be found.

So I figured out that I should reinstall the SDK (I was using 4.2)

After installation it said that somehow glide could not be found.

How to manually install Glide?

I was also missing HubAP5 in my toolbox…Why is that? Can i Install it manually?

Thank you for your support

I add a couple of pictures containing my problem

Thank you for your support!

I used a AP5 Hub in my recent Simon project

Its a nice socket expansion module


I know what the hub is.I’m missing it in my toolbox.I have the hub.It’s just not in my toolbox ( Please look at the pictures i’ve added to the post)

I also get a few errors containing Glide and Hub5 I don’t know what to do.

I add you the picture to the problem once more. Do you know how to solve this isue with Glide and HubAP5?

When I’ve seen that problem before it had to do with me updating my .NetMF version and I fixed it by reinstalling the GHI SDK and my modules came back.

I have done that a zilion times.

I am using Gadgeteer SDK 4.2

I don’t want to update it to SDK 4.3 because then i will have to redo a majority of my code. ( i think) …

Any other solutions? maybe i’m doing something wrong?

If it worked before then it should work now. I would remove everything, even visual studio, and reinstall. Or try on a different machine.

I will try that.

Also.How to manualy install Glide? Does 4.2SDK include Glide somewhere? I don’t remember how to install it.I know that it was very difficult.Can you refresh my memory how to do that?

I’ve updated a number of module drivers and such from 4.2 to 4.3 and its pretty easy, so you might for fun try that, but otherwise does the AP5 Hub module show up in the 4.3 list of modules, and just not in the 4.2 list?

I’m not talking about the drivers.I’m talking about updating the source code for a project (not the driver for a module)

You aren’t quite getting this.

You can install a later SDK version, and you do NOT have to update your code or your firmware on the device. The SDK allows backwards compatibility to different netmf versions. So the “latest” combination of netmf SDK and GHI SDK will give you the ability to still work on and target netmf 4.2, netmf 4.0 or even 3.x projects if you really wanted to.

So lets start at the beginning. What netmf SDK version did you reinstall? What GHI SDK did you reinstall ? And what components of the SDKs did you install ?

The problem remains (See picture bellow)

If I add a module it says that I’m missing a reference or something but as you see on the right corner the references are added.

First of all i tried to install this. : (Keep in mind that I need to use Glide in my projects)

So lets call it (Try Nr.1)

(In this try - step Glide and HubAP5 were missing) and the references did not work ( as i recall) I Installed these files in the numerical order.

3. (all checkboxes were checked - Speed ant other stuff were installed)

The Try 1 didn’t work.

Then i tried this stuff.

1. (The same SDK as in first try because i’m working with visual studio 2010 ,so it suggested installing this SDK)

2. (same core)

3. (Then I’ve installed this NETMF package,the updated on - 2013 r1)

In try nr.2 I’ve got Glide references that I’ve needed , but the project still does not work i get errors that I’m missing a reference or something. I’ve added the picture bellow.

Am I doing something wrong? Do you have any suggestions? I need to launch my project until Monday…

Thank you for your support on this problem.

P.S I have also tried to make a new project and retype the source code by hand. Still no luck

Problem solved.

Updated to the newest version of NetMicroFramework and SDK

1 Like

great to hear you sorted it out.

The problem you hit is because you were taking builds of SDKs from different source locations that were never used as the basis for a common build. The simplest way is just follow the bouncing ball that GHI have laid out that are all using the correct starting point and then target whatever framework you want. .NET Micro Framework – GHI Electronics