Main Site Documentation

How to have 4.1 and 4.3 at the same time


#1

Most work recently has been with 4.3 on G400 and G120 but today I have been asked to make some changes to an older ChipworkX based design.

I ran up VS2010 Express and when I try to load the project it tells me that this project cannot be loaded. :frowning:


The project type is not supported by this installation.

It also reports that the SDK was not installed correctly. I have uninstalled and re-installed with no success.

How can I get this to work?


#2

reinstall the MS-MF SDK 4.1 and or 4.2


#3

Tried to re-install 4.1 and still same error. I get the same error if I try to create a new 4.1 project.

:frowning:


#4

Actuall the GHI SDK 4.3 installer removes the MS-MF 4.2 assemblies and the support in visual studio. I re-installed MS-MF SDK 4.2 (not 4.1) and are able to work on older projects again 4.1 & 4.2


#5

No luck with 4.2 installed.


#6

did you use the microsoft SDK installer or the GHI stuff? You need MS sdk.


#7

Thanks Rob, that’s sorted it and the project loads and builds. :slight_smile:

BUT

The USB device does not show up in the project properties.

In device manager it shows as “GHI NETMF Interface” under the USB devices but nothing appears in the dropdown list.

The LCD is showing Deployment Application Mode.


#8

I finally got it but had to uninstall the current driver and get it to load the old ChipworkX one.

This is going to be as messy as hell when I go back to the G400 and G120 isn’t it?


#9

@ Dave McLaughlin -

Looks like time to use two computers… ChipworkX will have a new friend


#10

@ Dave McLaughlin - I think you will be fine as long add you use the exact same port on your pc?


#11

@ willgeorge - That’s what I do all the time. It also means I can use one to test the new stuff from GHI and NETMF and will know that the stuff I really need to support will still work just fine. Virtual desktops are also really useful in this regards too. I used to use the VM Workstation solution, but I believe there are free ones about too.


#12

I run the Oracle VM for Ubuntu to do Android Source development and I have Win XP VM I use for other software. The issue I have had is trying to get a USB device to connect to them.

How did you get this to work?


#13

I am using win7 2 PC, intel and amd, and I have 4.1, 4.2, 4.3 are installed on them. They are always happy to live in one house. :smiley: