Main Site Documentation

How Do I Reset N18 Display


#1

When I received the new Cerberus kit it worked as expected. After a few attempts to run some of the code examples all I get now is a white screen.

I loaded the Cerberus Kit Demo and it appears to work - I can hear the beeps and see the LED strip counting down - but just a blank white screen on the N18 display.

Apparently I’ve toasted it or gotten it into an unsupported state. Is there a method to reset the N18 Display Module to factory settings?

I’ve reloaded the firmware ( 4.2 and 4.3 ), and refreshed the bootloader too.


#2

@ dft277 - Have you tried changing the cable? Another thing to try is to move it to another socket, on the Cerberus the two ‘S’ sockets are 6 and 5, try both of them.


#3

Change the cable - nothing
Moved to another port - nothing
Moved back to the original port - nothing
Put the original cable back on - it’s working

It’s been working all day without problem, but I’m not sure why.

@ taylorza - thanks for the reminder in basic troubleshooting, I was trying to make the problem harder than it actually was.


#4

@ dft277 - That sounds like there is a bad connection somewhere? Glad it is working for you now.