Main Site Documentation

Holy Interference Batman!


#1

I’ve got a LOT of GPS units laying around. Mine and others alike.

If I power the Adafruit Ultimate GPS on a separate supply I get a lock, fast as you like. I can even put the Raptor (with 4.3" screen, LiPo, Ethernet and SD) just about right on top of this thing (seriously, we’re talking mm spacing) and maintain a lock.

So why then, is it the second this thing has anything to do with the Raptor power can’t I find a single Sat? None of my other GPS units do either (though I have one from GHI being overnighted).

I thought the power supply might just be crap, so I powered the unit separately connected the TX/RX and GND. That seems to work fine until the unit tries to send a message, then it loses the lock.

Any suggestions, at all, how I can get a lock on this thing while using Raptor? Kinda would like to have a working unit.


#2

Faraday to the rescue!

I can definitively say that the Raptor & Hydra spew out a lot of EMF. Using exactly the same module as before I places a metal mesh between the Raptor & the unit…lock achieved in < 2sec and holding steady.


#3

G400 the base of raptor has passed FCC and CE. Nor sure why you are having problems.


#4

Put your power module on a scope, and see how clean it is.

GPS is very sensitive to clean power.


#5

[quote=“godefroi”]Put your power module on a scope, and see how clean it is.

GPS is very sensitive to clean power.[/quote]

OK, I’m done. I’ve spent hundreds of dollars on different GPS modules. None of them work with this. I don’t care how sensitive they are to power. Why? Because I can hook any of these up to an Arduino with a 4.3" touch screen and it’ll work instantly.

I’ve tried USB power, wall power, LiPo power.

This is a Raptor, a screen and a GPS. It’s not that freaking difficult. And I’m tired of it being that difficult.

I will write this project on Arduino. It will be a lot slower, it won’t have fancy USB support and WiFi like I wanted, but the darned thing will work.

Time to walk away from NETMF for a good long while. :wall: :wall: :wall: :wall:


#6

There have been previous reports of dirty power from the SMPS on GHI’s power modules…


#7

I’ve also tried the power module from Solder Monkey.

The real point is I have thousands of dollars of NETMF equipment and I can’t even get a GPS to work. That’s pretty ridiculous.


#8

@ Skewworks - The EMC / EMI characteristics might change as soon a wire is connected to a board, in this case your G400.

You can try to add a ferrite filter around the cable between raptor and the GPS device.

for example : http://nl.farnell.com/ferroxcube/csf38-12-25-3s4/ferrite-core-flat-cable-26-7mm/dp/898594


#9

I haven’t gotten GPS to work in an acceptable manner on any Gadgeteer board other than the Cerberus.


#10

@ andre.m, @ godefroi - what GPS modules do you have and what boards did you try it with?


#11

I’m not looking to troubleshoot any issues here, just noting that there have been reports.


#12

Yup, I’m with you. Reports were specific to Hydra.

The catalog page even says the GPS won’t work with Hydra. It does say it works with everything else. And with Raptor being FCC and CE certified, you would think something as simple as GPS would work.


#13

G400 is certified but Raptor may be not.


#14

Any feedback from GHI other than it should work?


#15

In the interest of proper testing, I removed all components from my Raptor except the GPS unit. I’m powering it with the GHI DP module. 5 minutes and counting not even a hint at seeing any satellites, let alone having a lock.


#16

@ Skewworks - Could it be a communication issue between G400 and GPS or do you believe that the GPS signal is disturbed by RF noise from the G400?


#17

I see the NMEA data coming through so the communication is fine. 2 of my 4 different GPS modules also have a fix indicator LED to visually inform me of locks.


#18

Let’s keep the thread to those who have problems and want to troubleshoot please then.


#19

@ Skewworks - Have you tried or are able to test with a ferrite as proposed in #9


#20

Would you like us to try it out with the GPS you have? If so, can you mail it to us and we will. Let you know. Since we already have the seeed module, we will test on Monday.