HID Global Mifare-Reader with Hydra

Hi I have been trying to communicate with this reader/writer over the serial-module for a while now: http://www.hidglobal.com/prod_detail.php?prod_id=30

No reaction, not one…I set up the code an initialized the serial port with these values: salesforce.com

Nothing helped, does anybody here maybe have some advice or experience with such devices connected over the serial-module?

If you setup a serial datarecieved event do you get any data at all?? In theory this should be just like using an RFID chip/module.

I assume that you mean the RS-232 module when you say “serial module”.

You have not posted any code, so I can not comment on how you are reading and writing to the module.

I would start diagnosis by doing a loopback test. I would put a jumper wire between the RX and TX pins of the RS-232 connector and then write a small program that writes a few bytes and then reads. If I am able to read what I sent, then the module and code are functioning properly.

1 Like

@ hugh, have both events set up, none fires :confused:

Hi mike,

Yeah the rs-232, man I’m not getting the names right lately.

This is how I initialize the rs-232 module, the events just print to debug that something happened:

rs232.Initialize(57600, GT.Interfaces.Serial.SerialParity.Even, GT.Interfaces.Serial.SerialStopBits.Two, 8, GT.Interfaces.Serial.HardwareFlowControl.NotRequired);

            rs232.serialPort.LineReceived += new GT.Interfaces.Serial.LineReceivedEventHandler(SerialPort_LineReceived);
            rs232.serialPort.DataReceived += new GT.Interfaces.Serial.DataReceivedEventHandler(SerialPort_DataReceived);

as soon as I find a whire I will try you test, thx in advance

We are lucky that we had another rs232 module lying around, the first one was faulty, no reaction when i placed the wire(staple) between the two pins.
The second one worked like a charm… thank you very much mike!

EDIT: In the end it wasn’t the module anyway, it was the gadgeteere cable that wasn’t working, replaced it and now both work. Sometimes it can be so easy and our problem is that we think to complicated :confused:

OK, back to the beginning, the event doesnt fire anyway, it only fired when I placed a wire between the RX and TX pins.
The thing that gets me is, that it shows that there is data available, but the event is not fired…tried it on a hydra 4.1 and a cerberus 4.2.

then maybe try swapping what you think is RX and TX. UART Dyslexia perhaps ? (I love the first community post on this https://www.sparkfun.com/products/449 )

1 Like