Main Site Documentation

Help, problem with Serial-to-USB eblock for debug


#1

Hi all,

i have updated my panda2’s firmware at 4.1.8 with SDK4.1
i have plugged eblock on tx and rx, and MOD with GND

but i can’t upload/debug via serial port… i don’t understand why!

i have tryed to make a echo server like this:

public static void Main()
        {
            byte[] buffer = new byte[16];

            SerialPort UART = new SerialPort("COM1", 9600);
            UART.Open();

            while (isRunning)
            {
                int blen = UART.Read(buffer, 0, 1);
                UART.Write(buffer, 0, blen);
            }
            UART.Close();
            Debug.Print("COM port closed.");
        }

but don’t wont work!
i see the light od TX on eblock blick, but nothing, nothing happen…

someone can help me?


#2

@ Hurry

you have setup the device for serial debugging and then are using the serial port in your application? you can not do both.

release the mod pin to make your code work.


#3

Hi Mike,

yes i release the MOD pin, but don’t work


#4

Besides what Mike said, did you connect Rx to Rx or Rx to Tx? It should be crossed.


#5

@ Gralin
i don’t understand, i have plug Tx -> Tx and Rx -> Rx for echo server.

it’s a same for debug via serial post?


#6

What are you trying to achieve?

Are you trying to debug via the serial port, or are you trying to just use the serial port?

Usually, when you use the serial port for debugging, you want to use the USB client port
for another purpose, and therefore need to move the debugging functionality from
the USB client port to a serial port.

You are trying to use the serial port for an echo server. Why do you want to move
debugging and loading to the serial port?

Also tx->tx and rx->rx is incorrect. tx->rx and rx->tx is the correct wiring.


#7

@ Mike

I want use a serial port for upload and debug, because i need the usbhost for BT connection

unable to use it, I tried to create an echo server to try to work eblock.

now i inverted a plug, tx -> rx and rx ->tx and panda can send a string to pc, but i cant send a message to panda, because i don’t know what is a correct char for terminate a command cr or lf


#8

Tx->Rx and Rx->Tx, unplug MOD, it’s work
Solved for echo server. Thank you for help!

Now, i need to understand why i can’t upload and debug via serial port, Tx->Rx and Rx->Tx, plug MOD and GND.
i receive this error: Error 1 Device not found or cannot be opened - Serial:COM2

(in Device Manager i have only USB Serial Port (COM2) )


#9

have you selected the proper com port in the project properties?

have you tried to ping the board ith mfdeploy?


#10

yes COM2, but MFDeploy can’t ping

Pinging… Error: No response from device

When i try to debug via serial port, a TX led start to blink, and don’t nothing happen

Serial port speed set at 115200

It’s needed a resistor for MODE plug GND?


#11

By the way, Bluetooth is not supported on USB host. You can use serial Bluetooth module.


#12

http://wiki.tinyclr.com/index.php?title=PS3_Controller


#13

Are more than one serial ports appearing with mfdeploy?


#14

@ Mike,
yes, when i plug the usb, appearing a COM2

following http://wiki.tinyclr.com/index.php?title=USB_Client#USB_Debugging_with_Virtual_COM_Channel at Serial (COM) Debugging i listen the sound only when i plug the usb of serial port (like the guide) but the ping don’t have answer


#15

No.

If you hear a sound when ypu plug in the serial to USB cable, then something is being seen by the PC.

Have you checked to see if there is more than one COM visible on the PC.

Check the Device Manager and see what appears/disappears when you plug/unplug the cable.


#16

Normally there is only COM1, after connecting the eblock appears COM2 named: USB Serial Port (COM2)


#17

Ok, it appears that a COM2 appears when you plug in the FEZ. That is good.

But, you are unable to ping from MFDeploy. This sounds like there is
an issue on the FEZ side of the serial to USB converter.

I believe you said if you remove MOD, and wire COM1 TX-RX your echo
server works. This would say the FEZ is working properly.

How are you wiring the converter to the component shield? How
are you grounding the MOD pin while using the component shield?


#18

PC sounds like when it detects a new device

Yes, correct

I have FEZ Connect Shield plug over Fez Panda 2, and i connected MOD and GND on Panda 2 and eblock on FEZ Connect Shield


#19

Long shot… Check the cables.


#20

Mike, you talk about the cable of that i used for MODE and GROUND?
Or the cables for a eblock?
For eblock i use the original cables

i try to change a cable for mode and ground, nothing work