Main Site Documentation

Help a Newbie with getting reliable results debugging


#1

I have a solution (for Panda) that has multiple projects. I expected that the project set as the Startup Project would be loaded when i hit F5. This appears not to be the case. I am starting to wonder if I need a separate solution for each Panda code project and cannot easily switch between them as i imagined. Is that correct? What is happening when I set the Startup project and then tell it to run? What gets deployed? Thanks

And, what is the story with “Sometimes I have to reboot the Panda to start the debugger.” Do we need to hit the reset button before each run? It seems like maybe I do.

Great fun! Great product! Great community!
Bob


#2

I have had this happen to me. I think this usually happened after a GHI SDK update. Did u just do an update? If you did an update, did you delete the GHI references and re-add them?

I think I also have had this happen when I had a MF project and a full .NET project in the same solution. In this case, I just split it into two solutions.


#3

Your expectations are good :slight_smile:
The project set as the StartUp and the referenced projects will be deployed. The StartUp Project will run

Make sure you set the correct deployment device for all projects : project Properties-> .NET MicroFramework -> Deployment


#4

@ Mike I have a solution with multiple MF projects and multiple FF (full framework) projects and and changing the StartUp Project works as expected :slight_smile:


#5

Such fast replies - you guys are great.

I did update to the latest SDK before this started happening - but I am such a newb I had never tried it this way before. I did UNINSTALL the previous SDK first. I did UPDATE Firmware.

I have created a new solution with just the one project and now it works properly - I will go back and try the multiple project solution and double check the deployment stuff.

The symptom was that I often get “The system is not in an initialized state, rebooting” and it never finishes and sometimes there are deployment errors. It seems to help if i reset the Panda fuirst.


#6

OK, I have double checked and it is definitely NOT loading the code from the startup project on to the board.

Project 1: Blink led 20/second.
Project 2: Blink 5 / sec.
Project 3: Blink 1 / sec.

I have startup set as project 1, but Project 3 gets run. But breakpoints from project 3 do not get hit (neither do BP in P1). The debugger seems to think it is running 1, but the code on the board is blinking 1/sec. I did make sure that the code on the board was previously blinking at a different rate, so i do know that something new was deployed and is running.


#7

OK, I do have a solution that is working with a single project - with a blinking LED and an interrupt driven button handler! Woo Hoo!

So, maybe the multiple project solution I have is corrupted or something and I will just move on for now. I will add another project later and see what happens.

I really do appreciate you verifying that it SHOULD work the way I expected. I hope to be unnewbified enough to start contributing soon.


#8

OK, now that I am back on track, this is way TOO freekin’ easy! Getting the interrupts to work was straight out “worked first time”. Works just like C# should. Getting analog inputs from the Joystick shield…worked first time! I am starting to expect that my projects with FEZ may just work the first time! This thing really rocks!


#9

That is the what .NET MF, and FEZ is all about. Everybody tastes success :slight_smile:


#10

Guys, I don’t want to pollute the boards, but I am so excited about my little successes and need a place to share it.

I now have my serial 4 digit LED class running using the Sparkfun part
(http://www.sparkfun.com/commerce/product_info.php?products_id=9767)

I built it using the FEZ components model. It went really freakin’ easy.
I will post it to Fezzer when i get it documented.

My team has been building many of our most recent projects using PIC32. I am seeing that a .NetMF solution is definitely the way to go for some of our needs.

Thanks again for all of your help.


#11

Bob,

I know what you mean … I get positively giddy about how FEZ this stuff really is. I have tried to get more into the hardware side a number of times, but there were always so many hurdles and a long learning curve. With FEZ I can leverage my existing skills to do some really cool stuff. (Cool to me anyways.)

Looks like we are going to have a rainy day here in Texas tomorrow and that is a good excuse to spend the day playing with NetMF and skipping the yard work. ;D

-Eric


#12

We love hearing your FEZ stories


#13

Guys, I am still having trouble understanding what is going on with multiple projects in a single solution. It really does appear that the debugger does not always pay attention to the project that I have set as the Startup Project in the IDE. I am back to my initial situation: I have a project that blinks the LED at 10/sec and a project that blinks 1/sec. For a while I can switch between them successfully. Now I add another project to the solution, and no matter what I do, it always deploys and runs the 10/second version of the code. But, I cannot set breakpoints in that code because the debugger seems to think it is running the 1/sec code.

This is very confusing (and making development more difficult). Any ideas about what is going on?


#14

I’ve been able to work around that issue by selecting Build > Configuration Manager and only checking Deploy for the project that I want to deploy/debug in addition to setting startup project in Solution Explorer.


#15

Thanks Hari. That would do it. I wonder why the issue is happening?