Main Site Documentation

Having trouble deploying if I use Ethernet module


#1

If I make a project, just with main board and multicolor LED and all I do is set the LED red in ProgramStarted - it works fine, as expected.

The moment I go to the .gadgeteer editor and add the Ethernet J11D module, connect it to the mainboard, then save. I make no changes to my .cs code.

When I go to deploy, I get this error in the console.

Any ideas?



Invalid native checksum: GHIElectronics.NETMF.Net 0xB7F1767D!=0x310788CC

Resolving.

Link failure: some assembly references cannot be resolved!!


Assembly: Gadgeteer.WebServer (2.41.0.0) needs assembly 'Gadgeteer' (2.41.0.0)

Assembly: Gadgeteer.WebServer (2.41.0.0) needs assembly 'System' (4.1.2821.0)

Assembly: Gadgeteer.WebServer (2.41.0.0) needs assembly 'System.IO' (4.1.2821.0)

........

Error: a3000000

The program '[8] Micro Framework application: Managed' has exited with code 0 (0x0).
Waiting for debug commands...



#2

Have you loaded the latest firmware on the Spider?


#3

err - nope, and almost as soon as I hit post, I read:

I was hoping to avoid that as I use a Mac with XP on VirtualBox and while deployment all works fine, VirtualBox stops allowing the USB connection to forward to the VM as soon as you set the little dip switches on the Mainboard in preparation for the firmware upgrade.

Anyone met or even better resolved that problem? I don’t really want to inflict the entire Visual Studio stack on a friends PC just to update the firmware - probably once.


#4

I do firmware upgrades on a IMac using Fusion.

Sometimes, with Fusion, I have to manually connect a USB device to the virtual machine. Fusion does not always automatically forward new USB devices to the virtual machine.

In Fusion, there is a USB device menu item, under VM(?), for connecting and disconnecting devices to the VM.

I have not used Virtual Box.


#5

Thanks Mike - I’ll have a play - now I know its possible on a VM.

I’m a few versions behind on Vistual Box too. Think I’ll start by updating that.

Si.


#6

AH, got it!

For any other VirtualBox users out there, unlike ordinary usage of the Spider, to update the Firmware, you have to create an ‘open’ usb filter, rather than one specific to the device you plug in.

For your VM, go to Settings then select Ports, then USB, then click the blue dot to create an open filter that will catch all USB devices and pass them on to the VM.

THEN plug in your device with the dip switches already in the right position.


#7

Thanks for sharing.