Main Site Documentation

Hardware question from software guy


#1

OKay, I admit…My hardware skills are not up to the same level as my software skills, so forgive the newbie questions…

I have a question about the 5v pin on the gadgeteer socket… Is it truly supposed to be 5v?

Im trying to use that pin to power a custom module with some other 5v modules on it. I was noticing some strange behavior, so I took a voltmeter to it.

I am using a benchtop supply to provide exactly 5.00v to the usb connector of a USB DP power module.

If I measure the 5v pin directly from the gadgeteer socket on the DP module, it is 4.993 volts.

Okay, close enough, I guess

When I connect this to the D socket on my Raptor (or Hydra) then connect a breakout module to a cable and plug it into any other socket, then measure the voltage, I get something like 4.662 volts.

If I connect another random module to one of the other sockets (led, flash module, wifi module, etc) when I plug one in, the 5v pin drops to 4.53v then another module plugged in, and the 5v pin drops to 4,43v , and so on (each new module drops the voltage)

The 3.3v pin, however stays at 3.317v

Is this
"haha, silly software guy, this is normal, 5v is never really 5v, deal with it"
or
"dummy, look at the schematic, you are getting that result because of (some hardware secret here"
or
"dude - you got a bad USB DP power module, return it for a replacement:"?


#2

@ mtylerjr - The voltage drop is a result of the ohmic resistance of gadgeteer cable, pin to pin resistance of the gadgeteer connectors and pcb traces. The voltage drop increase the more power you consume. More modules means more current. (U=I*R) U=voltage drop I=consumed current and R=resistance of cables + pcb traces + connector contact resistance.

± 5% voltage tolerance (0.25 Volt) is in general acceptable for 5 volt logic. However depening on the type of your module it might still work with a lower voltage.


#3

I’m not an hardware expert either, but this looks like as if your power supply can not provide enough power.
To me it looks like as if the voltage drops more and more when you add modules.

You write you apply the 5V to the USB mini connector, right?
1st. does your power supply has an current regulator? At which current does it start to reduce the voltage then?
Have you tried to supply 7V (or more) to the Power connector on the DP module (I’d say 2Amps or more)?
What do you see then.
Take a look at the schematics: Is the 5V rail passed through directly from the USB connector to the Gadgeteer socket? if not. you might have some voltage drop there, if the Amps go above what is typical for USB (250mA).
You can also apply the 5V directly to the Gadgeteer socket. but you also need the 3V3, and your voltage should be exact and clean.
And by the way: Most modules only need 3V3. A Raptor would run, even 5V is zero. But some modules will not.


#4

I made a little module that had an adafruit VS1053 DSP codec module with microsd, a Parallax Emic Text to Speech module, and an arduino nano to control them. I issue instructions via a raptor UART from a U socket, to generate speech, or play one of a few hundred .Wav/.MP3 files on a microsd card on the adafruit vs1053b module.

The module works great when I use the 5V power supply to power it (I can send instructions from the raptor to generate speech, or play sound files off the card) but when I try to power the thing from the 5v pin on the U socket, the arduino and codec chip run, but the voltage drops too much to power the 5v Emic TTS module, which hears the serial commands (it shows a red light when it receives a valid string), but wont generate any audio.

Its a bummer, because I was going to just need one U socket to have .wav/.mp3 dound effects and text to speech for the small robot car I am building - but now I need to find another way to power the thing, or start over.

As I said, I’m primarily a software guy. My plan was essentially “Okay, just connect all the wires, write the code, and go!” - I just assumed 5V would stay 5V.

It works… I just need another 5V power source on my robot now, I guess.


#5

The DP module has a chip with a programmable(probably with a resistor) current limiter. Do you have any way of measuring the current draw?


#6

I’ll check tomorrow. Its 11PM here. It’s been a long Christmas day here in NZ. I got sunburned hanging out with family in the backyard - way too hot and sunny. Need to sleep.

Merry Christmas to everyone.


#7

Ah… it was a defective USB Client DP module. I borrowed one from a colleague and his worked (I get 5v on the 5v pin and my frankenmodule works fine)

I ordered a replacement. I wish shipping wasn’t so slow and costly to New Zealand … my colleague needed his back.

GHI: As a Christmas present, If you feel like upgrading my shipping on my replacement order (instead of the hassle of me returning the defective module from NZ) the order is
#12252014-7E9B

(I’ve bought $693 worth of modules and boards aver the past 23 days… just saying :smiley: )

If not, that’s OK. It can’t hurt to ask, right? :smiley:

As a side query, are there GHI Employees in NZ?


#8

Please give him back.


#9

Don’t worry I’m working on a plan where we are sending in the black helicopters and sneaking him out of the country.

Like I said its going to be a good year for Gadgeteer.