Main Site Documentation

Hardware class checksum mismatch


#1

I now have a Fez Domino to play with. When I try to compile, I get a checksum error. I have read that this is caused by a version mismatch, but I am not sure how to correct this. I tried updating the firmware using my computer, and all I get is the FEZ to say bad firmware and be bricked until I get to another computer. I reinstalled the GHI stuff with a fresh copy and the problem persists. I thought it might be that I am in a virtualbox, so I moved by code to a friend’s computer and tried with a fresh firmware flash from his machine. Same checksum error, but his code builds just fine. Both of us got the files provided in the downloads section of this site, so I am not sure what to try from here.


#2

Can you ping the domino with MFDeploy ( it should be on the start menu “microsoft.net framework 4.1” then in the tools folder,

If you start the MFDeploy and first check if the USB see’s the domino listed as “USBizi” we can take it from there.

Cheers Ian


#3

Forgot to mention the default program builds and runs just fine. I can do pretty much anything that only needs the default libraries. I have a problem when I start trying to use anything other than the default FEZ library. That is what really puzzles me.

BTW, I can ping it using MFdeploy.


#4

So when you connect to teraterm and you have invoked the bootloader… what happens then? can you retrieve the version number and start an update?

We know the applications won’t deploy if you are running incompatable firmware…I found it was mainly “GHIElectronics.NETMF.Hardare”

So you need to work out why you can’t update the firmware.

Cheers Ian


#5

starting simple…

With MFDeploy, tell us what firmware version is on your device.
From the README file from the GHI SDK, tell us what the VERSION that it is meant to be.


#6

According to the Readme, the GHI version is “GHI NETMF Library V 4.1.3.0”.

Every Version MFDeploy gives

ClrInfo.clrVersion: 4.1.2821.0
ClrInfo.clrVendorInfo: Microsoft Copyright © Microsoft Corporation. All rig
ClrInfo.targetFrameworkVersion: 4.1.2821.0
SolutionReleaseInfo.solutionVersion: 4.1.1.0
SolutionReleaseInfo.solutionVendorInfo: GHI Electronics, LLC

I guess there is a version mismatch based on what is listed here, but I am not sure how to correct this.

When I open tera-term to re-flash, I can read the version number as 1.07. Then I type Shift+X to start a transfer. I get the .GHI file from the USBizi folder as per the instructions. I then send it using X-modem and the 1K option. The FEZ takes the firmware (100% transfer) and then prints back to the terminal “BAD FIRMWARE” and will do nothing outside of the boot loader until it is re-flashed on another computer.


#7

Please watch the video and see if the versions match, in the release notes and what you see back from MFDeploy http://www.youtube.com/watch?v=CEvLqhQrfE4&feature=player_embedded


#8
  1. Are using teraterm from this website?
  2. If yes, please copy the firmware file from the SDK to your desktop and try to flash again.
  3. Make sure the file size is not zero.

Answer these 3 questions and you will be good to go :wink:


#9

Works now. I don’t know why. I was using Tera-Term from Tera-term’s webstie, but so is my friend and he didn’t have this problem. I also updated vitualbox, so I guess that could have made a difference also. I really don’t know what to blame at this point. Thanks for the help.