Hard day with USB and my Fez.Spider

First, I have to say that I was a ‘bit’ more than just upset… But I survived the day anyway.

I have been having a lot of issues with my Fez.Spider USB driver. Namely the GHI .NET Micro Framework USB Debugging Interface.

After trying to deploy an application (that has worked in the past) my Spider went into the endless-loop thing and it was all downhill from there…

I uninstalled the GHI NETMF USB Drivers 64-Bit (I have Windows 7 64 Bit) and then rebooted my PC. After reboot, I reinstalled the USB driver. No luck… The USB driver would not install and MFDeploy could not find the USB EMX_Gadgeteer (Spider). So I then headed for the Windows registry. To my surprise, I found out that I was not allowed to delete the Key or any of the Subkeys for the GHI .NET Micro Framework USB Debugging Interface so I could start fresh.

(HAY! It is MY PC nobody else’s!.. Why then am I not allowed to do what I need to do?)

I could not set permissions that would allow me to delete the key. Maybe I just forgot how to do it correctly? After a few hours getting nowhere really fast… I remember that I had this little ‘jewel of code’ that I found sometime ago. This ‘jewel’ of a program allowed me to delete the registry key and start over. All is well again after deleting the key and reinstalling the GHI USB driver (Using GHI NETMF USB Drivers.msi).

I am NOT advocating that changing anything in the Windows Registry is the best thing to do but sometimes it is the ONLY thing you can do when it comes to hardware divers. This is not only GHI’s USB driver but other drivers I have has issues with in the past.

Before you do anything else.
CREATE A RESTORE POINT so that you can go back to original settings if something goes wrong.
CREATE A RESTORE POINT so that you can go back to original settings if something goes wrong.
Yes, I said it twice…

The ‘jewel’ can be found at View any installed/connected USB device on your system

There is a 32 and a 64 bit appliction. I run the application (USBDeview.exe) using ‘Run as administrator’. Usage of the program is well documented and it works. Just be sure you are only removing what you intended.

In the program look under the columns VendorID 1B9F and ProductID for 0102. This is the device to remove. Click on (select) this line and using the menu ‘File’ select ‘Uninstall Selected Devices’. A dialog box will come up asking 'Do you want to uninstall the selected devices?. Click the Yes or No button.

Important: Be sure that you have only ONE item selected. The line of text will have a blue background. (Multiple items can be selected so be careful.)

If you look in the registry you will no longer see VID_1B9F&PID_0102. I suggest that you reboot your PC. The application does NOT remove the GHI USB driver. It only removes the Key/Sub Keys from the registry. I would suggest that you reboot the PC again and then plug the USB cable into the Spider and watch for the Driver installing message in the Windows Task Bar. After the driver installs you should again see the VID_1B9F&PID_0102 in the registry with only one Sub Key under it.

Registry Info:
GHI .NET Micro Framework USB Debugging Interface In the Device Manager it is called:
Debuggable.Net Micro Framework Device / GHI.NET Micro Framework USB Debugging Interface

Registry KEY deleted (All keys/subkeys) found at:
May also be found at/in HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Enum\USB\VID_1B9F&PID_0102

All I know is it ‘fixed’ my problem and I am back to playing with my Fez.Spider.

Do not get me wrong…

I LOVE my little toy Spider! I have as much fun with it as I did when I put together my Mits Kit 8800. I had one of the first to be shipped and all programming was by the front switches… What fun! Ed Roberts invented the 8800 and it sold for $297, or $395 with a case. The machine came with 256 bytes of memory (expandable to 64K) and an open 100-line bus structure that evolved into the S-100 standard. I finally got a paper tape punch and reader off of an old RTTY Teleprinter and then I could even save my programs. No USB to worry about either… Cost me a few hundred to interface the punch and reader using TTL chips… More FUN!

Ya all have fun!