Guide does not work. Please update it

I’m trying to get Gadgeteer to work on either VS2013 (computer1) or VS2015 (RC) (computer2).
Both are failing, and I cannot fathom why:

  1. I make sure to install Micro Framework 4.3 (QFE2)
  2. Downloaded and installed GadgeteerCore.msi
  3. Tried both packages:
  • GHI Electronics NETMF SDK 2015 R1 Pre-Release 1.exe
  • NETMF and Gadgeteer Package 2014 R5.exe

Before each run, I make sure to un-install everything to start “fresh”

End result is the same on both computers - nothing shows up in VS2015. In VS2013, I gett errors stating that the Micro Framework Version is wrong.

Can someone please help me solve this?

Have you installed the Visual Studio Integration for the Micro Framework as well?
There are seperate visx packages for VS 2012, 2013 and 2015 (downloadable from
Not sure if the Gadgeteer core is already avail able for VS 2015.

Yes, I did. Going to try the latest 4.2 package now to see if THAT works

Here’s what I have installed and such (image included) I’ve highlighted all the things that I’ve installed. Prior to each attempt, I uninstall all of those and start from the beginning. Error message is there too.

Does any of the packages do registry keys that I need to remove manually? I feel I’m just doing the same dumb thing over and over again

You can test each step before going to the next. So uninstall everything then only install vs2013 then test a Windows c# app.

Second install netmf and make sure you can build something and run in three emulator.

Also, in your first post, step one is actually 2 installations. Install both please.

Uninstall VS2013 VSIX (from extensions&updates - removed it there)
Uninstalled .Net Micro Framework from control panel
Uninstall VS2013

Installed VS2013 Community Ed.

  • Can write a console APP & debug it: OK
    Exit VS2013

Install netmf-v4.3.2-SDK-QFE2-RTM, installed with option “Complete” OK
Install netmfvs2013.vsix OK
Start VS2013, create Micro Framework project console app

  • Created a console app
  • Emulator pops up on debug/F5
  • obtained string “Hello World!” from the default code
  • OK
  • Exit VS2013

Installing from

  • Installer pops up, runs for a while “Configuring Visual Studio”
  • Installation Successful
  • Starting VS2013 reveals nothing new

Installing NETMF and Gadgeteer Package 2014 R5

  • Uninstall option is presented, uninstalled everyhing
  • Re-ran the installer
  • Get the message “Successful install”
  • STart up VS2013, looking for Gadgeteer - nothing shows!
  • Attempt to run the VS2013 vsix fails with the message “It’s already installed”

I’m at a loss! The guide is NOT working for me :frowning:

Could you explain more waht you mean by “Nothing is in VS”? Can you post a screensot of the “new Project” window?
How does the Version conflict Show up?
Please post screenshots/Output prints of the Errors you get.

There is no “Gadgeteer” project type under C# in VS2013 after a fresh install, by that I mean “nothing”
There is no version conflict that I know of. Installers do not complain when I uninstall all before re-attempting
There are no errors at this stage, only from VS2015, which I’ve given up on already. My problem now is to get this working in VS2013

What I find strange is that there are no VSIX files for Gadgeteer itself, only for NetMF - how are project types added for Gadgeteer? and I dont see any project or item templates in the VS folders.

Which logs should I be looking for?

The Gadgeteer templates are installed with the gadgeteer core.
For the Micro Framework SDK the VS plugin was seperated for easier updating.
If you have the microframwrok SDK and visx installed you should have new templates in VS like in attached Image.
I do not have gadgeteer installed, because I don’t Need (use) it.

If you create an NETMF Console Application you should be able to do some quick LED blinky test Project.

The documentation page from gadgeteer core on codeplex Dows not list VS2013.
Not sure if’s supported.
Any gadgeteer Folks here who know this?

Weird, I’ve had this working before in VS2013, and still do on my laptop! Are there experimental /alternate locations to install from?

I have „SDK 2015 R1 Pre-Release 1" running on my PC with Visual Studio 2012 and VS 2013.
Be sure that you install the right versions of NETM ( and Gadgeteer Cor (NET Gadgeteer Core 2.43.1000). You get the right versions i f you go over the links of GHI  Support  .NET Micro Framework.

VS2013 is supported and used by many developers.

Which Os are you running on? I’m trying to get this working on Windows 8.1 and Windows 10 (build 10130)

@ digitaldias - Windows 8.1 (32 Bit)

I have installed it (without Gadgeteer) an many (10+) Win7 x64 and Win 8.1 x64 Computers.
Never had any issues like that.

Well, I’m well on the way now, but still not satisfied.
I’m able to write to the Hydra using the Micro Framework, but I still dont understand fully how to set up the program correctly, so it’s slow and error prone. Are there any guides on how to work a Gadgteer mainboard using .Net Micro framework only?