Main Site Documentation

GPS stops working


#1

Hello,

I have a problem with GPS module, which after 2-3 minutes (from the time when the position is found) stops “updating” the position (even time in Debug window stays the same)

Looking closer at the problem, using NMEA sentence following output appears in debug window:

NMEA Sentence: $GPGGA,140250.00,5055.66210,N,00122.86415,W,1,06,6.96,10.3,M,47.0,M,7B
NMEA Sentence: $GPGGA,140250.00,5055.66210,N,00122.86415,W,1,06,6.96,10.3,M,47.0,M,7B
NMEA Sentence: $GPGSA,A,3,05,08,09,15,28,26,7.58,6.96,3.00
0C
NMEA Sentence: $GPGSA,A,3,05,08,09,15,28,26,7.58,6.96,3.00
0C
NMEA Sentence: $GPGSV,3,1,10,05,69,268,32,06,02,019,07,48,059,22,08,75,114,3378
NMEA Sentence: $GPGSV,3,1,10,05,69,268,32,06,02,019,07,48,059,22,08,75,114,33
78
NMEA Sentence: $GPGSV,3,2,10,09,78,142,33,10,37,150,28,15,11,274,31,26,46,274,3272
NMEA Sentence: $GPGSV,3,2,10,09,78,142,33,10,37,150,28,15,11,274,31,26,46,274,32
72
NMEA Sentence: $GPGSV,3,3,10,27,01,029,28,21,138,2771
NMEA Sentence: $GPGSV,3,3,10,27,01,029,28,21,138,27
71
NMEA Sentence: $GPGLL,5055.66210,N,00122.86415,W,140250.00,A,A70
NMEA Sentence: $GPGLL,5055.66210,N,00122.86415,W,140250.00,A,A
70
NMEA Sentence: $GPRMC,140251.00,A,5055.66209,N,00122.86405,W,0.132,210214,A*65

for the first 2-3 minutes output is fine- accurate position etc

however, after this time GPS starts to print strange statements, which are no longer parsed:

NMEA Sentence: $GPGGA,140341.00,5055.66306,N,00122.86522,W,1,060,0,2,028,27,8,4,GP7*,N.0$GPRMC,140342.00,A,5055.66323,N,00122.86519,W,0.574,210214,A65
NMEA Sentence: $GPGGA,140341.00,5055.66306,N,00122.86522,W,1,060,0,2,028,27,8,4,GP7
,N.0$GPRMC,140342.00,A,5055.66323,N,00122.86519,W,0.574,210214,A65
NMEA Sentence: $GPVTG,T,M,0.574,N,1.063,K,A
21
NMEA Sentence: $GPVTG,T,M,0.574,N,1.063,K,A21
NMEA Sentence: $GPGGA,140342.00,5055.66323,N,00122.86519,W,1,0,02905,5$G30,24,6,47225.6,1$GPRMC,140343.00,A,5055.66351,N,00122.86511,W,0.613,210214,A
6B
NMEA Sentence: $GPGGA,140342.00,5055.66323,N,00122.86519,W,1,0,02905,5$G30,24,6,47225.6,1$GPRMC,140343.00,A,5055.66351,N,00122.86511,W,0.613,210214,A*6B

i.e. prints RMC statement in the same line as GGA,

what is more some of the statements are cut in the middle:

NMEA Sentence: $GPGGA,140346.00,5055.66474,4B
5,20130645,0527
$874,46$GPRMC,140347.00,A,5055.66485,N,00122.86515,W,0.984,210214,A
64
NMEA Sentence: $GPGGA,140346.00,5055.66474,4B
5,201306*45,0527

I used Spider mainboard
I used the code from GHI website (the simplest one with GPS only)
I tried different firmwares (most recent ones)
I tried USB and 9V battery to power mainboard
I followed all the “official” instructions
I tried 3 different GPS modules- all show the same problem
I tried different sockets

I followed all the instructions and everything should work fine. Is it possible that there is something wrong besides hardware?


#2

Do any of the other events in the driver provide valid output, such as PositionReceived. Additionally, is InvalidPositionReceived ever fired?


#3

I wanted to collect other sensors data as well: for example temperature and humidity sensor gives valid output even after GPS stops- if I run a program with other sensors.

PositionRecieived was what I tried first- but it stops after mentioned 2-3 minutes.


#4

Nothing from InvalidPositionReceived? Can you remove all other modules and just do a basic GPS test program?