GHI NETMF v4.2 and .NET Gadgeteer Package Corrupt


Just downloaded the “GHI NETMF v4.2 and .NET Gadgeteer Package Beta” package three times and all three times I cannot unzip it. It is in an unknown format or damaged.

I am really trying to get set up in the 4.2 environment so I can code in VB.Net - which is my language of preference.

can we get this Zip file fixed?


I have also confirmed that the zipfile is corrupt. Please correct!

I had that problem trying to open the file with 7-zip, but Windows Explorer (ZipFolder, bleh, I hate it) opened it and extracted the files.

Are you on Windows 8, by any chance?

No, Windows XP Pro using WinZip. I then downloaded the “Do not use” beta dated 8/10 and that worked and installed. I am just getting started with the Panda Ii and netmf. I am having a hard time finding and examples written in VB. Maybe now is the time for me to switch to C#. I tried a simple flash an LED but cannot see how to define a FEZ Panda II pin for the OutputPort.


Hi Don, FYI, Panda II is not supported with a Netmf 4.2 firmware, so you can’t use VB. C# targeting Netmf4.1 is the platform you need to use.

Also, I’ve just downloaded the SDK again, and that was linked in this article
It worked fine for me, opened in Win7 Explorer and I could navigate into the files and extract it all.

Just downloaded and checked, all worked fine.

If you are using panda, please stick to the beginner guide ebook and internet of things ebook

I also just tried it and both files unzipped. Have you tried unzipping without using WinZip? What broswer/version are you using?

Thanks for all the replies. Seems like I barked up the wrong tree with the Panda. VB support in NetMF 4.2 is the main reason I went in that direction and ordered the ultimate kit. Will the Panda II FIRMWARE be updated to support NetMF 4.2?

Please do not mix multiple thread with similar questions so we can follow your questions and help you better. I have provided a detailed answer to your other thread here

Welcome to the community and we look forward to seeing your project, VB or c# are welcome :slight_smile:

Sorry, didn’t mean to do multiple threads.

Just had the same problem with the download. Winrar fails the archive but windows 7 build in zip handles the archive…

I’m using 7-Zip, it doesn’t like the zip file.

Just because Windows’ built-in compression tool opens the file doesn’t mean it’s not corrupt.

Yep 7-zip can’t open! We have something to investigate now.

I’m using Win-Zip and Winrar WIndowsXP … downloaded through Firefox and i get corrupted file…

I was able to extract the Zip using this freeware tool.

you can use it until GHI fixes the issue.

one more thing to report … the installer failed to install the USB Driver… it threw an error about not being able to open the file … but i was able to browse to the driver folder x64 and install it …

using windows Xp 64bit

JayJay, Windows XP has a built in ZIP/UnZIP utility. No need to download/use anything else.

Oh yah i forgot about that … you are right you can just right click and hit explore…

Downloads should now be able to be unzipped using 3rd party programs. This also fixed another issue which allows pause/resume of downloads.

Yep it works