Main Site Documentation

GHI NETMF USB drivers problem


#1

Hi there

I’m trying to install the GHI NETMF USB drivers but I get this error message (see picture). The installation is incomplete for some reason.

I’m using windows on a MAC (bootcamp)

Visual Csharp and the other software runs smoothly apart from the drivers

I thank you in advance for your help guys,

Jaume


#2

Did you forget to post your screen shot?


#3

sorry, here it is


#4

nope, still not :slight_smile:


#5

here is a closer shot


#6

The installation is interrupted. I have only ever seen that message when someone aborted an install part way thru (hitting cancel basically). And you’re sure this happens, the same error, when you attempt to install it multiple times?


#7

@ Jaume Miro - Other customers have reported success with Bootcamp. It would be useful to know which version (exact) of Windows you have installed. You may find other useful information by using the Forum Search function. Although we don’t routinely use bootcamp ourselves, if you can narrow the problem down and report relevant software package versions we may be able to help.


#8

https://www.ghielectronics.com/community/forum/topic?id=1330&page=3 is one of the bootcamp threads, the only option posed there that hasn’t come around before is to install the driver manually outside the MSI


#9

Thank you very much for your help guys. I really appreciate it

the version of WIndows is Windows 7 Home Premium Service Pack 1

I created a log during the installation and I have posted a shot of the bit when the errors start to come out. I can post more shots as well.

In the end of the log there is an message that literally says:

MSI © (C4:D8) [14:31:14:647]: Product: GHI NETMF USB Drivers – Installation failed.

MSI © (C4:D8) [14:31:14:648]: Windows Installer installed the product. Product Name: GHI NETMF USB Drivers. Product Version: 1.0.0. Product Language: 1033. Manufacturer: GHI Electronics. Installation success or error status: 1603.

Again, thanks so much

Jaume


#10

the first three shots are from the beginning of the log. The last one is from the end. To cover everything I will need something like 12 shots

thank you very much!


#11

yes, I am the admin on the system.

the 4.2 version gives the same message about the incomplete installation :frowning:

it is strange because all the drivers work apart the GHI mainboard.

Are the cerberus drivers special perhaps?

Thanks for replying my messages


#12

Do you use the windows control panel to Uninstall/Remove all components (GHI * ) before attempting to re-install? If not, please do so, especially “GHI NETMF USB Drivers”. Then only attempt to install 4.2 SDK (unless you have some good reason/need for 4.1). In summary:

[ol]uninstall via [em]Control Panel->Programs and Features[/em] anything that starts with GHI
follow the instructions (exactly) on http://www.ghielectronics.com/support/.net-micro-framework[/ol]


#13

thanks for helping guys.

it seems that with a Bootcamp the drivers should work.

I will install the bootcamp drivers for windows again to see what happens