GHI Electronics NETMF 2016 SDK Pre-Release 1

We are excited to announce the preview release of the GHI Electronics NETMF SDK 2016 R1. We worked diligently for the last few months to provide a very stable and user friendly SDK. These updates include but are not limited to:

[ul]CDC over USB client on G30
G120 and G400 can now update TinyBooter though In-Field Update
G400 now uses the new GHI Bootloader to update TinyBooter
SPI displays on G30, G80, and Cerberus can now use custom widths and heights
PPP now works with more modems
WiFi RS9110 is now more recoverable when corrupt
BrainPad project templates are included for C# and Visual Basic
Signed USB CDC drivers are now included when using the default VID and PID
Legacy Gadgeteer mainboards and boards in GHI.Pins no longer warn about being obsolete
Networking improvements in SSL, Accept, and Read.
Minor changes to pin organization and naming conventions in the libraries[/ul]
While this SDK is very stable, there were several deep changes that require more testing on top of the many hours already spent testing the updates. This preview release should not be used as a production release until the official release in the new year.

Unfortunately, with all of the good news we do have a bit of bad news. With the community’s help, we have discovered multiple issues preventing us from supporting Visual Studio 2015. As of today, we are only supporting Visual Studio 2013. All issues have been passed on to Microsoft and we hope to have a solution in the future.

Also, in order to use this pre-release SDK you will need to install the newest Gadgeteer core. The support page will be updated for the final SDK release.

Enough with the SDK it’s time to celebrate! To celebrate the holidays with the end of another successful year and the release of this preview SDK we decided to take the last week of the year off! We will be closed from December 25th, 2015 through January 4th 2016. Please keep in mind that no orders will ship this week but we will get right back to it in the new year.

2015 .NET Gadgeteer Core:


[quote]G120 and G400 can now update TinyBooter though In-Field Update[/quote] sweeeeeeeeet! I’m wondering how well SSL seeds will persist though or can the config region persist when updating everything else…

Way to go GHI nice work and a nice xmas present.

To bad about 2015 though but since the year is almost over I’m quite confident those found undocumented features are too.

In any case happy holidays to every one in this forum !! :dance:

Surely Devin will still be on the job?

No way. IFU Tinybooter?? I must be dreaming, somebody wake me up…


@ Simon from Vilnius - the holiday season calls for a special feature made by our awesome engineers, enjoy :slight_smile:

You’re much more agreeable when you are sleeping… :smiley:

@ networkfusion - If you update the config region, the seed will be lost. But you can try and look into using the Configuration class that was added in 2015 R1 to try and read/write the seed between updates.

Nice Christmas present. Thanks to all at GHI for the hard work.

Now to enjoy Christmas with the family and start on the PPP work tomorrow :slight_smile:


Hmmm - tried to install and didn’t get very far. After accepting the license terms on the first setup screen, setup fails looking for the Wix attached setup called “NETMF SDK”. Just me, or is anyone else encountering this?

(Win10 also flags this as an untrusted executable, but the setup itself seems to be signed, so I am not sure what it is complaining about there)

EDIT: SOLVED (sorta) - The download was getting corrupted. It seems to be some environmental weirdness on my end. I was using a wonky internet connection and either that was truncating the file, or Kaspersky was doing something odd, but the combination of disabling smartscreen, Kasperskey and switching to my 3G hotspot seems to have solved the problem. I suspect that it was the internet connection and that is why smartscreen was triggering (because the file hash did not match its whitelist).

The new SDK installed within about 5 mins on my WIn10 machine but the Gadgeteer SDK is still stuck around 90% for the last hour and everything else on my PC grinds to a halt. This seems to happen every time I try to install any VS stuff from MS.

Excellent work guys. I now have working PPP with the SIM5320E modem and was able to send data after about 30 mins of code work using a modified cellular modem driver.

The PPP is very fast to make the connection too so very impressed with the work put into this. Thanks for going the distance and purchasing a SIM5320 to do the testing with.

GHI rocks.


[quote]All issues have been passed on to Microsoft and we hope to have a solution in the future.

@ Gary is there any chance of you making the issues public community can pressure MS at this end as well…!?

Also, is the “update ssl seed” issue ever going to be fixed?

@ Gary is there any chance of you making the issues public community can pressure MS at this end as well…!?

There are discussions on the forum already about issues with vs2015.

There are discussions on the forum already about issues with vs2015.

would mine be one of them


What issue?

the one that is proposed in the task tracker, i.e. you click the “update SSL seed” and nothing happens issue… I have also just tested in the latest prerelease…

@ networkfusion - I didn’t find it on the task tracker?

It is on there, It starts with “Unable to set SSL seed”. I would post the link but windows 10 mobile is being an ass… And the fact that I am still able to type after this amount of alcohol
is either a really good auto correct or amazingness… ( i am going with amazingness as I have re read the post and I haven’t got double vision… Yet…)