Main Site Documentation

GHI Debug Interface USB connection to PC


#1

Hi Folks,

just tried to move to real work and put the board into my lab. There I connected the board to a USB HUB and … nothing.

After connecting to the PC directly it works.

This is a really big constraint, because there were very few USB sockets on current PCs and mounted at strange places, so it will be MUCH more EASYER to use a hub.

Where is the problem with that???

With best regards

Gerhard


#2

what device if any shows in device manager?

Have you tested with any other device connected to that hub, for example move the keyboard over to the hub?

Most likely this is power related. Is it a powered hub, what device are we talking about (your G400 or EMX DevSys, or others?) and what peripherals are attached? Many older PC USB ports are woeful at providing enough power to run anything more than the standard device with nothing attached…


#3

Hi Brett,

… it shows no device manager, just like there is no board connected. But power is ok, board is running, as far as I can see.

… other device is working, try with USB stick.

The hub is a industrial rated 7 Slot USB 3.0 hub and there is no other device connected as the EMX development board.

No peripherals attached to the EMX DevSys board.

I will try with external power later, but I think, power isn’t an issue, but will carfully check.

So, you want to told me, that it should work, and there is no rule like ‘No hub, only direct …’.

Ok, will try it later afternoon (CET).

With best regards

Gerhard


#4

… but direcht Connection works, just the hub is the Problem, as it Looks for now.


#5

Not true. The USB3/win8 problem is related to the gin loader, the virtual serial, not tinybooter or debugging.


#6

@ Gerhard - we always recommend using a powered hub so you are not relying on the power coming from your PC.


#7

… ok.

Yes, I tried different ports on the hub and I checked them with an USB stick.
The HUB is connected on the back of the PC.

I tried than a socket at the front. maybe this is 2.0, dont know have to check later.

I run Win7 Pro, not Win8, so this should Little easier …

With best regards

Gerhard


#8

Ok, issue solved:

On laptop, works directly, because I used USB 2.0 port, high current out (also used to load mobile phones …)

PC in my lab: Front socket, direct connection works, socket is USB 3.0

PC in my lab, but USB 3.0 hub: USB sticks working, but EMX DevSys only with external power supply attached to the hub. As I currently carry out some renovation to my working places, this supply was accidently off, sorry.

Facit: EMX DevSys is good on USB 3.0 / Win7 pro directly, or by external powerd hub.

Thanks for helping.

With best regards

Gerhard