GHI Bootloader interface fail to start

Are there any known issues with the GHI Bootloader interface when using Windows 10 with the latest updates?

I am using Windows 10 Pro with all (known to me) updates.

I needed to update a older Spider to but the loader does not start.

I have, in the past, used the Bootloader interface but that was before the several Windows 10 updates.

GHI Bootloader interface (COM6)

Removed in order listed.

  1. Microsoft .NET Micro Framework 4.3 (QFE2)
  2. Microsoft .NET Gadgeteer Core
  3. GHI Electronics NETMF SDK 2016 R1

Reboot and install in order listed.

  1. Microsoft .NET Micro Framework 4.3 (QFE2)
  2. Microsoft .NET Gadgeteer Core
  3. GHI Electronics NETMF SDK 2016 R1

Running Windows 10 Pro
All current updates are installed.

Error received in Device Manager:

This device cannot start. (Code 10)

{Operation Failed}
The requested operation was unsuccessful.

Events in order:

  1. Device USB\VID_1B9F&PID_0104\6&ab382be&0&1 requires further installation.
  2. Driver Management has concluded the process to add Service usbser
    for Device Instance ID USB\VID_1B9F&PID_0104\6&AB382BE&0&1 with the following status: 0.
  3. Driver Management concluded the process to install driver
    \ghi_bootloader_interface.inf for Device Instance ID USB
    \VID_1B9F&PID_0104\6&AB382BE&0&1 with the following status: 0x0.

I was having exactly the same error message. After reading your post I tried the same board on a Windows 7 machine and everything ran perfectly.

@ willgeorge - It’s likely the same issue with the EMX bootloader being unable to run on Windows 8+. We haven’t been able to track it down yet and the only work around when it occurs is to use Windows 7, as @ Greg Norris suggested.

Keeping Windows 7 has been the pain.

@ John -

I just tried one of my other PC’s that is also running Windows 10 Pro. It has all of the latest updates and it works fine.
No Bootloader error!

Probably makes no difference, but the two PC’s have different Windows 10 builds?

Images attached.

1 Like

Here are some ways to get Windows 7 still

Here is the Windows 10 build that I couldn’t get to work.

@ willgeorge - The issue only happens on some computers, so it’s like a combination of the PC hardware, the EMX, and Windows 8+. You can actually also try to update over serial on Windows 10.

@ John -

Thanks for your info.

I should have checked before but I just found out my HP laptop only has USB 3 ports. (No USB 2) so maybe that is the reason.

I have to look for the info on using a serial port to load the Bootloader.

Have a GREAT day!

@ willgeorge - To update using serial mode, you’ll want to move all four of the DIP switches, not just the first three. Then connect a USB to serial module to socket 9 (COM 1). You can use FEZ Config to deploy the loader and firmware or TeraTerm to deploy the loader.

@ John -

Thank you!