Main Site Documentation

GHI Boot Loader Interface, This device cannot start (Code 10)


#1

Sorry, everyone, but I’ve Googled for hours and read through this forum as well.
Nothing I’ve tried works.

Here’s my setup and what I’ve tried:
Windows 7 64-bit.
.NET MF SDK 4.2 (QFE2)
GHI NETMF v4.2 and .NET Gadgeteer Package 2013-02-14
Using a powered USB hub (have tried with and without)

After installing all of the above:
With USB disconnected and switches in “Default” mode, I connect the USB:
The USB driver installs correctly and “Debuggable .Net Micro Framework Device” shows up in Device Manager.
I can use EMX Updater to ping and get firmware version (4.2.7.0) just fine.

However, when I flip the switches to “GHI Loader” mode, hit reset button on board:
The USB driver attempts to install, but warns that “Device driver was not successfully installed”.
Device Manager shows “GHI Boot Loader Interface (COM6)” with yellow yield/exclamation, it’s device status is "The device cannot start. (Code 10).

I have attempted to manually update the driver (using the “Have Disk…” method) with the one located at:
C:\Program Files\GHI Electronics\GHI NETMF USB Drivers\USB Drivers\GHI_Bootloader_Interface
It chugs on it for a moment, then finishes with “Windows encountered a problem installing the driver software for your device” (Code 10 again)

Looking deeper, Event Viewer leads to this:
Version=1
EventType=PnPDeviceProblemCode
EventTime=130060708137869821
Consent=1
ReportIdentifier=a174611a-7d79-11e2-a6dc-005056c00008
Response.type=4
Sig[0].Name=Architecture
Sig[0].Value=x64
Sig[1].Name=Hardware Id
Sig[1].Value=USB\VID_1B9F&PID_0104&REV_0100
Sig[2].Name=Setup class GUID
Sig[2].Value={4d36e978-e325-11ce-bfc1-08002be10318}
Sig[3].Name=PnP problem code
Sig[3].Value=0000000A
Sig[4].Name=Driver name
Sig[4].Value=usbser.sys
Sig[5].Name=Driver version
Sig[5].Value=6.1.7601.17514
Sig[6].Name=Driver date
Sig[6].Value=11-21-2010
DynamicSig[1].Name=OS Version
DynamicSig[1].Value=6.1.7601.2.1.0.256.48
DynamicSig[2].Name=Locale ID
DynamicSig[2].Value=1033
FriendlyEventName=Could not load driver software
ConsentKey=PnPDeviceProblemCode
AppName=GHI Boot Loader Interface (COM6)
AppPath=C:\Windows\System32\rundll32.exe
ReportDescription=Windows was able to successfully install device driver software, but the driver software encountered a problem when it tried to run. The problem code is 10.

I’ve tried to install the other drivers per this:
http://wiki.tinyclr.com/index.php?title=WinUSB_vs_NETMF-USB
But, every other possible combination results in “The folder you specified doesn’t contain a compatible software driver … for x64-based systems”

I’m hoping I’m missing something really obvious.
Greatly appreciate some help so that I can successfully update the firmware via the “GHI Loader” mode and then proceed with development.

Regards,
Fred


#2

I have no idea if it will help but I have had a similar problem but not exactly as you describe.

As a quick try… Power of your PC. Change your powered hub to a different USB port on the PC.
Power up the PC and see if you receive a new driver install pop up window…

I’m using Win7 64 bit also.


#3

I also have no direct experience to assist here, but have another suggestion

Remove the driver - and use the “remove the files” option, and then reconnect the device and install the driver again.


#4

Hi Everyone,

Taking willgeorge’s advice this morning, here’s what solved this problem for me.

With my PC turned off:
Moved my powered USB hub from the USB 3.0 port it was in and used a USB 2.0 port that was available.
Powered on my PC.
Connected power to my powered USB hub.
Completed the USB connection to the back of my powered USB hub - observed Windows installing the driver for it successfully.

Next, I made sure that my FEZ Spider 1.0 switches were in “GHI Loader” mode.
I then connected the USB from the “USB Client DP” board to my powered USB hub… success

There are two things I noticed that may have made this work as a result of trying a different USB port:
(1) The new port in use by my powered hub is USB 2.0 instead of USB 3.0
(2) The COM port allocated was COM 10 instead of COM 6 (maybe COM 6 had a conflict?)

I fired up the EMX Updater and was able to successfully update the firmware:
– Log –
No response from device. (I pinged it at this point, but I guess it doesn’t listen for pings when in “GHI Loader” mode.)
Connecting to device… (Here on down is a result of clicking update, took default settings for files, etc.)
EMX found at Port#: COM10
GHI Bootloader Version: 1.02

Device will be updated automatically! DO NOT disconnect or turn off the device!
Erasing…
Erase successful!
Updating TinyBooter. Please wait…
Update successful!
Disconnecting COM10
Rebooting…
TinyBooter updated sucessfully. Version number: 4.2.9.0
Updating Firmware. Please wait…
Deploying C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\EMX\Firmware\Config.hex … successful!
Deploying C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\EMX\Firmware\Firmware.hex … successful!
Deploying C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\EMX\Firmware\Firmware2.hex … successful!
Rebooting…
Firmware updated sucessfully. Version number: 4.2.9.0
Updating TinyBooter and Firmware is done!

Thank you all for the ideas to get me past this!
Fred


#5

I had same problem. The solutions was using USB2.0 adapter on my notebook that have only USB3.0


#6

Solved to me as well.

FEZ Spider Boot Loader Interface seems to have some incompatibility with USB 3.0


#7

Same issue here (with EMX based FEZ Cobra), but can’t resolve it by plugging it into a USB 2.0 port.

Running Windows 8.1 64bit, version of usbser.sys is 6.3.9600.16384. Can anyone, with a working 64bit setup, post his/her version of usbser.sys?

Thanks.


#8

Same setup, exact same version on file. Not sure this file is relevant. Thinking that the EMX Cobra might require another setup?

My setup works with all other boards, but never tried Cobra I.


#9

Yeah, the driver at C:\Program Files\GHI Electronics\GHI NETMF USB Driver Set\GHI_Bootloader_Interface

only contains a .cat and .inf file, not a driver. It uses the default Microsoft CDC driver usbser.sys.

I think I’ll have to find an older, USB2 only, computer.


#10

Yes! Could update the Cobra on an older Win7 64bit notebook.


#11

Hello everyone,
I have a Problem with the FEZ Spider. Whenever i connect the Mainboard with the PC the PC searches for Drivers, that fail every time. Then i navigate to the device Manager and assign the Driver manually. After that the error code 10 appears.

The Board is not connected with an USB3 Hub. Moreover there is an external Power supply connected, too.

Does anyone know how to solve it?


#12

Welcome to the forum.

You probably need to move this to it’s own thread, this is ancient and is stamped as resolved, you might not get much of a response.

What I think you should be doing is to uninstall the driver, with the REMOVE FILES option so that you can get a chance to reinstall them fresh from the latest SDK (you do have the latest SDK, correct?). You should also tell us about whether this has just started happening, or if you’ve never had your Spider connected to this PC before (and whether you have had your Spider working before at all?). Then, one of the main causes for the USB device to not be recognised is power, so connecting a powered hub or using an additional external power source on a USB Client DP module should help. You should also disconnect any other external modules from your spider as that may help reduce power consumption to acceptable levels