Main Site Documentation

Getting Started with FEZ Medusa Mini on Mac


#1

I got the FEZ Medusa Mini in the mail this week and am working through the getting Started Guide found here: https://www.ghielectronics.com/docs/214/fezmedusa-getting-started However, I ran into an issue that the “FEZ Medusa” Menu item under tools does not appear.

So far what I have done is
[ol]Installed the Arduino Software from: http://arduino.cc/en/Main/Software
I have upgrade the drivers (so that it would be visible via USB-to-Serial) by installing the drivers found here: http://www.ftdichip.com/Drivers/VCP.htm
Installed the FEZ Medusa Libraries from the beta as mentioned in a previous post (https://www.ghielectronics.com/community/forum/topic?id=13669) by following the instructions for Arduino libraries: http://arduino.cc/en/Reference/Libraries[/ol]

Doing a little research (http://arduino.cc/en/Guide/Environment#thirdpartyhardware), it appears that I should install a “boards.txt” file to make the “FEZ Medusa” appear in the tool menu. The details of which are here: http://code.google.com/p/arduino/wiki/Platforms.

Is this the right direction? Can someone point me to an existing configuration file for “FEZ Medusa”?


#2

I am excited to see your question add this is the very first Medusa related question. I do not have an answer but others will get you an answer shortly. As you know Medusa is very very new so it is possible the docs need some improvements.


#3

You are correct - the Tools menu reads and shows devices that are listed in the boards.txt file. You need to replace the one that came with arduino software with the one from Medusa package.


#4

I didn’t see a boards.txt in the beta package. I’m looking at http://www.ghielectronics.com/downloads/beta/Medusa/BetaFramework.zip Is that where I should be looking?


#5

Hmmm. For some reason it is missing. May be GHI can shed some light.


#6

Found another link that has the file:

https://www.ghielectronics.com/uploads/Arduino.zip


#7

@ jhager - The thread you referenced was from an individual that just wanted to examine the framework, so I supplied a place/file to download the source and test examples. i.e it was not meant to be an installer for a working envirnoment. The package Architect recommends appears to have all the necessary components to deploy programs. I will check further on this when I get in my office. Sorry for the confusion.


#8

@ Jeff @ Architect - Thanks for the pointer to the package. I was able to get FEZ Medusa in the board menu by installing the hardware directory in the Arduino.app package.

When attempting to upload I still get the following error:

avrdude: stk500_getsync(): not in sync: resp=0x00

I am using the FEZ Medusa Mini if it makes a difference.


#9

Are you using the correct COM port?


#10

I have not yet received my Medusa boards yet. so just answering this in general about Arduino : Do you have any other boards connected? Especially something that might connect to the Rx line? This is an old Arduino problem that has stuffed my around before as well. The other think is to make sure you have enough power to the Arduino. Sometimes the USB cable alone is not enough to power it properly.


#11

I figured out my last issue.

I was connecting the board marked [U], the USB to Serial, to the [IPU Y] or [2] socket on the Medusa Mini. Clearly I should have been connecting it to the [PROG ] or [4] socket as indicated by https://www.ghielectronics.com/docs/215/fez-medusa-family and the instructions referenced for the FEZ Medusa.

Clearly a newbie mistake.


#12

Glad you got it working. Glad the Doc.s did their job (helped you solve a problem)!